jump to navigation

Access Media FastRate USB 100 con Linux! (II parte)

In Avanzate, per Guru!, Guide il 17/11/04 @ 16:06 trackback

Patchare e installare i driver

1) Prerequisiti

Prima ancora di pensare ai drivers installiamo alcuni prerequisiti:

per Mandrake 10 e superiori, basta dare (da root):

$: urpmi liblinux-atm1 kernel-source gcc libgtk+1.2-devel

PS: nelle varie versioni di mandrake questo pacchetto ha nomi diversi o sembra comunque introvabile… io non ho mandrake per cui vi chiedo di segnalare il nome del pacchetto nelle varie versioni. grazie!

Per gli utenti Fedora Core 2 e 3 mi e’ arrivato un suggerimento da Michele Reccanello:…vanno sostituiti i pacchetti glibc-kernheaders e linux-atm con quelli attualmente in sviluppo con la Fedora Core 4, dal sito :
http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/

Scaricati i 2 pacchetti si installano i sorgenti, si compilano e si installano i binari generati con questi comandi:

rpm -i nome-pacchetto.rpm
cd /usr/src/redhat/SPECS
rpmbuild --bb nome-pacchetto.spec;
rpm -i ../RPMS/i386/nome-pacchetto-i386.rpm

dopodiche’ si puo’ compilare il driver per il modem secondo le indicazioni della guida

Per tutti gli altri:

2) Installare i Driver

Procediamo procuriandoci i driver, disponibili a questo indirizzo, e salviamoli nella nostra “home”. Scompattiamoli:

$: cd /home/felipe (se non ci siamo gia', al posto di felipe
                    mettete il vostro nome utente :p )
$: tar zxf bast-0.9.0.tgz
$: cd unicorn      (il nome della dir dei driver appena creatasi)

Prepariamoci a fare le famose modifiche. Senza queste modifiche il modem potrebbe connettersi alla rete per pochi secondi, ad una velocita’ ridicola, per poi cadere o bloccare il kernel o fare un numero imprecisato di cose strane :)

Le modifiche sono in forma di “patch”, o pezza. Questo e’ un file che si applica ad uno o piu’ altri file per “correggerli” o comunque modificarli. Ho preparato questa patch con le correzioni. Salvatela nella directory che contiene i driver, e cio? se avete seguito le mie istruzioni, in /home/felipe/unicorn. Per applicarla:

$: cd /home/felipe/unicorn
$: cat bewan2fastrate_0.9.0_a.patch | patch -p1
   (notare che l'ultimo carattere e' UNO, non ELLE)

La patch viene cosi’ applicata e il comando ci dice quali file ha modificato. In questo modo i driver sono pronti per essere compilati, non ci resta che dare i seguenti comandi per compilare/installare i driver (e’ necessario essere root):

$: make
$: cp unicorn_usb/unicorn_usb_atm.ko /lib/modules/$(uname -r)/kernel/drivers/net/
$: depmod -ae

Bene, una volta fatta questa operazione abbiamo finito con i driver.

Prima di provare a caricare il modulo dobbiamo specificare nel file /etc/modules.conf che la “modulazione” qui in Italia e’ G.dmt. Per fare questo aggiungiamo una linea in /etc/modules.conf con questo comando:

$: echo "options unicorn_usb_atm ActivationMode=4" >> /etc/modules.conf

NOTA: Tiziana ha riportato che il suo modem funziona solo con ActivationMode=1, quindi provate le diverse impostazioni

Adesso non ci resta che testare il modulo dando un fatidico:

$: modprobe unicorn_usb_atm


Questo dovrebbe stampare a video una serie di messaggi, se lo fa e’ un buon segno. Possiamo dare un’occhiata a cosa dice l’output del comando ‘dmesg’, che alla fine dovrebbe restituirci l’amata scritta SHOWTIME_LO, che significa che il nostro modem si e’ sincronizzato! A questo punto siamo ormai vicini alla conclusione, non ci resta che installare una particolare versione di pppd con supporto per atm, impostare un paio di parametri e siamo pronti.

Oltre ai moduli per il kernel, il tarball bast-0.9.0.tar.gz installa un paio di piccole utilita’ che servono a gestire il modem, come bewan_adsl_status, unicorn_status, unicorntest, mentre dalla directory scripts possiamo “opzionalmente” prelevare manualmente il file unicorn-pppoatm e usarlo successivamente come script di init dal nostro runlevel preferito per avere la connessione direttamente al boot!

3) Installare e configurare PPPoATM

Per navigare con il protocollo ATM (Asyncronous Transfer Mode), e’ necessario recuperare una versione patchata di pppd.

per Mandrake 10 e superiori:

Gli utenti mandrake devono solo dare (da root):

$: urpmi ppp pppoatm

Per tutti gli altri:Io sto usando questa versione precompilata. Una volta scompattata in una directory qualsiasi, basta dare:

$: configure --prefix=/usr
$: make
$: make install

Bene, adesso abbiamo la nostra nuova versione di pppd installata, e possiamo gia’ viaggiare su internet, se abbiamo raggiunto lo SHOWTIME_LO nel test precedente. Assicuriamoci di avere un file /etc/resolv.conf in ordine, nel dubbio si possono inserire queste linee, che vanno bene con la mia Alice:

nameserver 151.99.125.1
nameserver 194.184.207.10

Adesso testiamo velocemete i driver creando un file chiamato options-atm, mettendolo in /etc/ppp/ e riempiendolo con le seguenti info:

user "nomeutente"
plugin pppoatm.so 8.35
noipdefault
usepeerdns
defaultroute
persist
noauth
nopcomp
noccp
novj
holdoff 5
maxfail 25

Al posto di “nomeutente” ci va il vostro vero nome, assegnato dall’ISP o scelto da voi, compreso di “”. Ecco pronto il vostro /etc/ppp/options-atm

Un’ultima cosa da fare e’ la sistemazione dei files che contengono la coppia username/password, che servono appunto per identificarci al nostro ISP. I due file in questione si chiamano /etc/ppp/pap-secrets e /etc/ppp/chap-secrets. La procedura e’ semplicissima: basta che i due file in questione contengano questa riga:

"nomeutente" * "password"

Ovviamente al posto di nomeutente e di password vanno il nomeutente e la password che vi ha fornito il vostro ISP per accedere al servizio ADSL, compresi di “”. Una volta fatto questo, per connettersi basta dare questo comando:

pppd file /etc/ppp/options-atm


Se tutto e’ andato bene, come spero, nel giro di pochissimi secondi siete in rete. Classica prova di “ping yahoo.com”, provate a lanciare il browser e se va tutto bene… siamo contenti.

Fatto, il tutorial finisce qui, la connessione funziona a me, e con un po’ di pazienza funzionera’ anche a voi, sarei contento di ricevere notizie del funzionamento del modem con i vari kernel e versioni dei drivers bewan, per cui se vi e’ andata bene fate un salto in canale e fatemelo sapere!

Connessione automatica all’avvio

A questo punto se vogliamo, possiamo rendere il tutto un po’ piu’ “professional” e avere un sistema che appena avviato e’ gia’ automaticamente connesso ad internet ;-)

Ho letto qua e la che “non si puo’ fare” e che “cosi’ il modem non funziona”… invece a me ha sempre funzionato, tranne in casi di avvio “traumatico” (corrente che va via, la mia presa difettosa che cede… -.-)

Per prima cosa conviene aggiungere il nome del driver nella “blacklist” di hotplug, cosi’ otteniamo che il modulo sia caricato solo al momento giusto, per fare questa operazione basta dare questo comando da root:

$: echo unicorn_usb_atm >> /etc/hotplug/blacklist

occhio a mettere “>>” e non “>” ! Questo fara’ si’ che hotplug non cerchi di caricare il modulo automaticamente. Testato su Mandrake10.1, grazie a dangp per la segnalazione! :)

Procediamo: usiamo come accennato prima il file unicorn-pppoatm che si trova nella sottodirectory scripts all’interno di quella in cui abbiamo scompattato i driver bewan. Quel file e’ un semplice script d’avvio in classico stile sysv (start|stop) e basta copiarlo in /etc/init.d/ (il nome di questa dir puo’ variare, in un slack e’ qualcosa come /etc/rc.d/) per averlo disponibile come script d’avvio.

Per “attivarlo” bisogna poi linkarlo al “runlevel” che usiamo di solito e che puo’ variare, come tutta questa procedura del resto, in base alla distro. In mandrake/fedora il runlevel predefinito con avvio grafico dovrebbe essere il 5, e quindi il comando:

$: cp /home/felipe/unicorn/scripts/unicorn-pppoatm /etc/init.d/
$: ln -s /etc/init.d/unicorn-pppoatm /etc/rc5.d/S35unicorn-pppoatm

ho segnato in grassetto la dir che contiene gli script per il runlevel 5. Tengo a sottolineare che per aggiungere/rimuovere o attivare/disattivare script d’avvio alcune distribuzioni linux hanno anche metodi grafici e piu’ semplici, che non conosco. In ogni caso questo appena esposto dovrebbe valere per molte distribuzioni linux simili a mandrake o fedora e derivate, o a debian (in cui pero’ il runlevel predefinito e’ il 2).

Buon Divertimento! :-)

Chi c’e’ riuscito? Eccovi delle schermate di qualcuno che usa il fastrate, mandatemi la vostra schermata a [email protected] se volete che la ggiunga qui, grazie!


grazie mikispag, che ha anche scritto una guida ottimizzata per mdk


grazie _ke, che ha scritto questa utility per configurare il modem


grazie geeko!


grazie matteo!


grazie tiziana :)


grazie nix!


grazie max!


grazie luca!


grazie davide (bizzu)!


grazie nikk che ha scritto questa guida per mdk 10


grazie matteo (dargor)!

Riferimenti

Se volete saperne di piu’ o volete risalire alle fonti delle informazioni o siete semplici curiosi… ecco i link che mi sono stati indispensabili per venirne a capo:

http://utenti.lycos.it/unarana/

http://xoomer.virgilio.it/dr_feelgood/index.html

http://www.da-silva.nom.fr/linux/adsl/pppoatm/mdk91-a888.html

http://www.google.it/linux


Pagine forse correlate:


Commenti »

1. Anonymous - 1/12/04 @ 23:32

Ciao mi spieghi come hai ottenuto quella maschera di configurazione di cui hai inserito lo screenshot nella guida? si da qualche commando in particolare?

2. felipe - 2/12/04 @ 2:55

credo ti riferisca a quella piccola app gtk: il comando è `bewan_adsl_status`. occhio però che non serve a configurare un bel niente, è una finestrella che mostra alcune informazioni, stop.

ciao

3. fabrizio - 7/02/05 @ 18:57

ciao…ho installato linux Suse 9 da 2 giorni! bel sistema…il problema ? il modem alice adsl fastrate100 :) ho letto molte guide sulla compilazione del kernel ma ogni volta che apro il terminale e d? il comando “make” o “make menuconfig” dice sempre file non trovato…ho provato 10 ore… :( e ho istallato tutti i pacchetti possibili immaginabili….il kernel ha version 2.6.5…ecc..garzie ciao…la mia email ? [email protected] l? rispondo prima

4. felipe - 7/02/05 @ 21:00

ciao fabrizio,

“file non trovato” non è granché come indizio :) incolla l’errore esatto compreso il famoso file che non trova e potrò dirti qualcosa, oppure fai un salto in canale

5. fabrizio - 8/02/05 @ 14:44

IO: entro in filemanager superutente (o anche normale) vado nella cartella /usr/src e poi linux2.6….. e poi apro il terminale e digito “make menuconfig”
lui mi d?: file not found
premetto di aver istallato tutti i pacchetti che hai consigliato anche nelle altre guide :(
come faccio a venire sul canale? :)
grazie ciao

6. felipe - 8/02/05 @ 16:06

clicca sul link in alto a destra con la scritta “Chat!”, devi avere java funzionante, o con un qualsiasi client IRC (tipo mirc per winzozz) collegandoti coi parametri segnalati in questo sito. non rispondere qui a faccende che non riguardano questo articolo, grazie

7. Anonymous - 9/02/05 @ 0:09

Ciao felipe, sono collegato in questo momento con il famigerato Fastrate! Mandrake 10.1 e driver 0.9.0.
Potresti spiegarmi a cosa servono le ultime 10 righe della guida? Quelle dove spieghi come dare un tocco “professional”… forse ? un po’ troppo professional per me :D
Che succede se le metto in pratica?
Grazie

8. felipe - 9/02/05 @ 14:59

ciao, effettivamente il tocco professional non è molto chiaro… adesso lo sistemo e chirifico, comunque serve ad avere la connessione automaticamente attiva all’avvio

9. Anonymous - 11/02/05 @ 21:00

Ciao sono un anziano completo profano
ho installato suse 9.2 non trovo la libgtk e make mi d?
una serie di errori.
hai qualche dritta o ? meglio
che io mi spari?

10. FDE - 20/02/05 @ 17:30

Per installare libgtk devi installare gtk-devel, non credo sia sul DVD di installazione, dovresti aggiungere alle sorgenti di installazione un repository FTP di suse. Per fare ci? devi: (1)leggiti la guida di suse su come aggiungere sorgenti di installazione, (2)connettiti in qualche modo a internet per avere accesso ai server che contengono i pacchetti di suse non inclusi sul DVD

11. felipe - 22/02/05 @ 0:43

c’è da dire che le gtk servono solo a compilare la piccola app che non fa praticamente niente… se l’errore riguarda solo le gtk il modulo dovrebbe comunque essere stato compilato. prova make install e verifica se te lo ha installato :)

felipe

12. Anonymous - 28/02/05 @ 23:24

Ciao, ho seguito le istruzioni
su una linux suse 9.2 con kernel 2.6.8-24. Il driver si compila, ma quando lancio modprobe unicorn_usb_atm ottengo un segmentation fault.

Sto usando i driver 0.9.0 con patch come qui indicato.

Dove posso guardare per cercare di fissare il problema?

13. Anonymous - 4/03/05 @ 3:47

Funziona alla grande…….sei mitico!!!

14. Anonymous - 13/03/05 @ 7:44

Funzia!
Grazie, Antimo

[[email protected] etc]# uname -a
Linux localhost 2.6.3-7mdk #1 Wed Mar 17 15:56:42 CET 2004 i686 unknown unknown GNU/Linux
[[email protected] etc]# ping http://www.google.com
PING http://www.google.akadns.net (216.239.59.104) 56(84) bytes of data.
64 bytes from 216.239.59.104: icmp_seq=1 ttl=245 time=201 ms
64 bytes from 216.239.59.104: icmp_seq=2 ttl=245 time=186 ms
64 bytes from 216.239.59.104: icmp_seq=3 ttl=245 time=1119 ms
64 bytes from 216.239.59.104: icmp_seq=4 ttl=245 time=249 ms

http://www.google.akadns.net ping statistics —
4 packets transmitted, 4 received, 0% packet loss, time 17808ms
rtt min/avg/max/mdev = 186.765/439.477/1119.656/393.396 ms, pipe 2
[[email protected] etc]#

15. Michele - 16/03/05 @ 18:36

ciao, ti ho scritto gi? una e-mail, cmq la riposto qui perch? penso che sia pi? consono.
Il mio problema ? che, dopo aver installato la mandrake 10.1, sono passato all’installazione dei driver. In fase di compilazione mi da due errori, in particolare non mi crea il file /unicorn_usb/unicorn_usb_atm.ko . Da che ? dovuto? ti ripeto che l’installazione ? assolutamente STANDARD!!. Grazie dell’eventuale risposta, ma mi salveresti dal definirmi un idiota. Miki

16. felipe - 16/03/05 @ 18:59

ciao Miki, ti ho appena risposto. aspetto i particolari degli errori

felipe

17. Luigi Zurolo - 16/03/05 @ 20:34

Ciao felipe, ho la Suse 9.2 e ho scaricato i driver 0.9.0 e la tua patch ma quando faccio il make arriva a questa riga
/bin/sh: /scripts/basic/fixdep no such file or directory
e termina con errore, poi vado a guardare nella directory unicorn_usb e mi ritrovo un file che termina per .o ..Cosa devo fare??

18. Anonymous - 16/03/05 @ 20:35

..sono Luigi, lo avevo scritto in name ma non me lo ha messo.

19. felipe - 16/03/05 @ 21:50

Luigi controlla di aver installato i sorgenti del kernel

felipe

20. Anonymous - 17/03/05 @ 8:47

Ce l’ho installati e nella giusta directory, li ho pure scaricati da kernel.org e sono gli stessi. Cmq, sono andato in quella directory e c’era un sorgente con lo stesso nome, l’ho compilato e adesso il make va avanti correttamente e si ferma a
/bin/sh: scripts/mod/modpost
ho provato a rifare la stessa cosa ma quando compilo modpost.c mi da errore perch? manca elfconfig.h..
Luigi

21. Anonymous - 17/03/05 @ 15:42

Scusami ancora felipe, finalmente sono riuscito a compilare i driver ho il kernel 2.6.8-24-smp ma quando lancio il modprobe mi esce questo errore:
FATAL: error inserting unicorn_usb_atm (..percorso file..): unknow symbol in module, or unknow parameter (see dmesg)
se lancio dmesg, in riferimento al modulo mi escono queste 4 righe:
..: no version for “struct_module” found: kernel tainted
..: unsupported module, tainting kernel
..: module license Property taints kernel
..: unknow symbol set_cpus_allowed
Cosa significa questo??
Luigi

22. Ottavio - 18/03/05 @ 14:51

Ciao Felipe ho seguito la tua guida e sono riuscito a connettere il sistema(MDK10.1) alla rete.
ho seguito alla lettera la guida ma ho riscontrato alcune difficolt?.
quando digito questo:
$: modprobe unicorn_usb_atm
non ottengo nessun messaggio.
Al riavvio il sistema si blocca quando cerca di rilevare nuovo hardware.
il problema viene risolto se rimuovo il modem durante l’avvio.
Ora non riesco piu a connettermi ne ad accendere la luce rossa sul modem
ciao e grazie di nuovo.

23. Anonymous - 18/03/05 @ 23:25

Finalmente sono riuscito ad installare il modem e a sincronizzarlo, ho installato i pacchetti atm e pppd patchato ma quando lancio ppp.. mi vengono visualizzate queste scritte:
Plugin /usr/lib/pppd/plugins/pppoatm.so loaded.
PPPoATM plugin_initialized
PPPoATM setdevname_pppoatm – SUCCESS
No QOS string in open_device_pppoatm()
Configuring backend for LLC encapsulation
ioctl(ATM_SETBACKEND): No such device
come mai non si connette? Cosa vuol dire l’ultima riga?

24. Anonymous - 19/03/05 @ 9:08

Ciao Felipe, sono riuscito a installare tutto e il modem si accende ma quando eseguo pppd file /etc/ppp/options-atm mi escono queste scritte:

Plugin /usr/lib/pppd/plugins/pppoatm.so loaded.
PPPoATM plugin_initialized
PPPoATM setdevname_pppoatm – SUCCESS
No QOS string in open_device_pppoatm()
Configuring backend for LLC encapsulation
Using interface ppp0
Connect: ppp0

e rimane fermo qua per? non ? affatto connesso, ho dimenticato qualcosa? Scusami e grazie ancora, Luigi.

25. Luigi Zurolo - 20/03/05 @ 8:46

Rettifico, il problema penso dipendi da questo: ho provato a lanciare unicorn_status e ricevo queste informazioni

Modem State : IDLE
Remote Report :
Last Failure : No hardware detected
Time Connected : –:–:–
Modulation :
Rate Us/Ds (Kbps) : 0 0
Cap. Occupation Us/Ds (%) : 0 0
Noise Margin Us/Ds (dB) : 0 0
Attenuation Us/Ds (dB) : 0 0
Output Power Us/Ds (dBm) : 0 0
FEC Errors Us/Ds : 0 0
CRC Errors Us/Ds : 0 0
HEC Errors Us/Ds : 0 0
Driver Version : 0.9.0
Firmware Version :

ho provato a caricare il driver con tutte e 4 le modulazioni ma ? sempre la stessa cosa, per? le luci del modem si accendono.
Luigi

26. Anonymous - 23/03/05 @ 14:56

Ciao Felipe, grazie per la guida, sono un neofita di linux, prima ero molto contrario a questo SO perch? troppo complicato da usare, adesso mi ci sto appassionando, cmq uso la Mandrake 10.1, quando scompatto il bast.. tar zxf bast-0.9.9.tgz non va, invece va con questo comando tar zxf bast-0.9.0.tar, per? nella directory unicorn_usb il file /unicorn_usb_atm.ko non viene creato quindi quando faccio la copia nella directory /lib/modules/$(uname -r)/kernel/drivers/net/ mi da errore, ho provato a copiare il file unicorn_usb_atm.o e poi rinonimarlo, e lo stesso non va quando do il comando modprobe unicorn_usb_atm mi da errore come posso fare per risolvere?
puoi risp. sulla mia mail [email protected]
ciao e grazie

27. Anonymous - 24/03/05 @ 23:08

scusa ? quando do il make che non mi crea il file unicorn_usb/unicorn_usb_atm.ko
come si pu? ovviare?

28. Anonymous - 31/03/05 @ 12:13

Come la devo salvare la patch visto che PER ORA uso internet da Windows ? Con quale estensione ?

Grazie
guido

29. DARKNESS - 11/04/05 @ 18:11

hola felipe,
ho letto tutte le guide che la grande rete potesse offrire e la tua ? quella che mi ha aiutato di pi?, anche se non mi ha portato alla soluzione del mio problema! infatti il simpaticissimo modem si connette hai giusti server Telecom italia, ma rimane in SHOWTIME_LO. Tieni presente che sono sicurissimo di non aver sbagliato (ho re-installato linux 6 volte!). Uso MandrakeLinux 10.1 su un computer con processore AMD Athlon 1800+ a 1533Mhz, una scheda madre MSI MS-6511 con chipset VIA VT8365A ProSavage KM133A, 640MB di RAM, una scheda video nVidia Geforce2 MX/MX 400 da 64MB di RAM…il driver che ho provato sul modem ? il 0.9.0
ciauz

30. Darkness_ale - 11/04/05 @ 18:18

This post has been removed by the author.

31. Darkness_ale - 11/04/05 @ 18:24

hola..sn ancora io
stavolta scrivo x aiutare colui ke scrisse “scusa ? quando do il make che non mi crea il file unicorn_usb/unicorn_usb_atm.ko
come si pu? ovviare?”
, a menoke nn lo abbia gi? fatto felipe…comunque alla fine della riga nn devi mettere .ko ma bens? .o

32. Darkness_ale - 11/04/05 @ 18:26

ehehehe…sn sempre io…ho dimenticato di scrivere “aiuto felipe, che devo fare? non rispondermi con frasi tecniche incomprensibili xch? sono nuovo tra gli utenti linux (circa 2 mesi)”
;o) ciauz de nuevo!
se mi devi scrivere la mia e-mail ? [email protected]

33. Anonymous - 11/04/05 @ 23:35

Ciaom ho appena installato mdk 10.1 e non ho avuto nessun problema e ho ottenuto showtime_lo con modprobe unicorn_usb_atm ma quando tento di connettermi la conessione dura pochi secondi e non capisco il problema

34. Anonymous - 13/04/05 @ 0:18

ciao
io utilizzo mandrake cooker 10.2
con kernel 2.6.11-6mdk
ho dovuto modificate il file
unicorn_usbdrv.c sostituendo a epmaxlenghtin ep_in e a
epmaxlenghtout ep_out
a quel punto riesco a compilare con qualche warning
il modem si accende ma non si sincronizza
hai provato a utilizzare il nuovo kernel?

ciao

35. Anonymous - 24/04/05 @ 23:34

Note: /etc/modules.conf is more recent than /lib/modules/2.4.29/modules.dep
/lib/modules/2.4.29/kernel/drivers/net/unicorn_usb_atm.o: /lib/modules/2.4.29/kernel/drivers/net/unicorn_usb_atm.o: unresolved symbol atm_charge
/lib/modules/2.4.29/kernel/drivers/net/unicorn_usb_atm.o: /lib/modules/2.4.29/kernel/drivers/net/unicorn_usb_atm.o: unresolved symbol atm_dev_register
/lib/modules/2.4.29/kernel/drivers/net/unicorn_usb_atm.o: /lib/modules/2.4.29/kernel/drivers/net/unicorn_usb_atm.o: unresolved symbol shutdown_atm_dev
/lib/modules/2.4.29/kernel/drivers/net/unicorn_usb_atm.o:
Hint: You are trying to load a module without a GPL compatible license
and it has unresolved symbols. The module may be trying to access
GPLONLY symbols but the problem is more likely to be a coding or
user error. Contact the module supplier for assistance, only they
can help you.

/lib/modules/2.4.29/kernel/drivers/net/unicorn_usb_atm.o: insmod /lib/modules/2.4.29/kernel/drivers/net/unicorn_usb_atm.o failed
/lib/modules/2.4.29/kernel/drivers/net/unicorn_usb_atm.o: insmod unicorn_usb_atm failed
ciao a tutti ,questo ? quello che ricevo dando il fatidico modprobe:Cosa vuol dire?
Premetto che uso slackware 10.1 ed una volta sola sono riuscito a raggiungere lo show time, ma non sono mai riuscito a connettermi perch? pppd mi dava problemi di librerie condivise.
Emiliano ciao

36. felipe - 25/04/05 @ 19:07

ragazzi, i commenti ammessi a questo articolo sono solo quelli che inneggiano a me come nuovo messia :)

a parte gli scherzi, per i problemi e le discussioni tecniche e’ molto piu’ comodo discuterne in canale su #linux-help @ irc.azzurra.org.

per favore quindi non ponete problemi qui e non mi intasate la posta con i vostri errori perche’ e’ difficile seguire tutte le mail, grazie :)

felipe

37. Anonymous - 17/05/05 @ 17:04

Ciao a tutti voglio far sapere a chi usa il fastrate USB 100 che ho scaricato QiLinux 1.2 riconosce il fastrate alla fine dell’installazione……. basta inserire nome utente e password e si navigaaa ciao a tutti clay rogers

38. Anonymous - 31/05/05 @ 20:20

Ciao Ragazzi!! questa guida ? pazzesca!
volevo chiedervi una cosA: alla fin fine la distro MANDRIVA supporta il modem fastrate 100? xk? io l’ho installata configuro la DISTRO per il modem fastrate 100 ma nn funzia :-(.. help me!!!

39. Anonymous - 4/10/05 @ 0:20

ottima guida.
soprattutto perch? a me funziona!!
installato su SLACKWARE 10.1 K 2.6.8.1
1^ connessione: dom 2,10,2005 3:15 pm (minuto pi? minuto meno).
GRAZIE. CIAO.
LUIGI1965.

40. Ale - 21/01/06 @ 17:12

Dopo molti tentativi anche io ce l’ho fatta!
adesso sono connesso con il fastrate 100
dalla versione Mandrake 10………ma come si fa a disconnettersi?….fate in fretta e da ieri che ci provo e poi non so più come pagare la bolletta!!…….grazie in anticipo

41. Pietro Vischia - 25/06/06 @ 11:20

A Emiliano che qualche commento più in alto chiedeva riguardo a

Hint: You are trying to load a module without a GPL compatible license
and it has unresolved symbols.

Questo è dovuto al fatto che i drivers hallo licenza “Proprietary”.

Come ho scritto in http://pietrovischia.altervista.org/articoli/fastrate_linux.php (per inciso, ora aggiorno i links a questo articolo, io linkavo ancora a pollycoke.org), per risolvere il problema, è sufficiente entrare in unicorn_usb/unicorn_usbdrv.c, cercare la riga MODULE_LICENSE=”Proprietary” e sostituirla con MODULE_LICENSE=”GPL”.

42. felipe - 25/06/06 @ 12:47

Ciao Pietro, grazie per il commento e per il link, conoscevo già la tua guida. Al momento sembra una delle più aggiornate e affidabili

43. Luca - 7/08/06 @ 12:00

Ciao volevo solo chiedere se questa guia è applicabile anche alla versione live di slax

44. felipe - 7/08/06 @ 13:26

dipende dal kernel usato in slax, non è detto che abbia tutto il supporto necessario

45. Turi - 6/09/06 @ 0:13

il link per la patch nn m funziona…!

46. spliff - 7/11/06 @ 18:50

Salve, tutto ciò funziona con fedora core 6? l’ho appena istallato e sono ancora un igorantone di linux

47. spliff - 7/11/06 @ 18:52

PS: neanche a me funzioa il link con la pack

48. DoOm5 - 3/01/07 @ 1:55

Salve, volevo comunicare che nn funziona il link con la patch, cioè questo:
https://pollycoke.net/2004/11/17/access-media-fastrate-usb-100-con-linux-ii-parte/FastrateUSB100/prot/bewan2fastrate_0.9.0_a.patch
Per il resto tutt’ok.

49. Anonimo - 21/01/07 @ 12:32

Ho seguito tutto. Dopo 3 giorni di fatiche sono quasi riuscito a far funzionare il modem. Ho usato però il driver bast-0.9.3 su mandriva 2006. Il modem si illuminava, però non connetteva dicendo che non trovava pppoa.so. Ora però il mio problema è che non riesce più ad accedere a linux e si ferma su: “Caricamento interfaccia ppp0″ . Cosa è successo?

50. Anonimo - 25/01/07 @ 15:17

NON FUNZIONANO I LINK DELLE PATCH se qualcuno è cosi gentile da inserirle su un host free ne sarei grato grazie :P

51. matteo - 1/04/07 @ 19:36

ciao,
scusate ma ho qualche problema quando faccio il make del driver.appaiono gli errori:
[[email protected] unicorn]# make
for i in adsl_status unicorntest tools ; do make -C $i all ; done
make[1]: Entering directory `/home/Napisan/unicorn/adsl_status’
make all-recursive
make[2]: Entering directory `/home/Napisan/unicorn/adsl_status’
Making all in intl
make[3]: Entering directory `/home/Napisan/unicorn/adsl_status/intl’
make[3]: Nothing to be done for `all’.
make[3]: Leaving directory `/home/Napisan/unicorn/adsl_status/intl’
Making all in m4
make[3]: Entering directory `/home/Napisan/unicorn/adsl_status/m4′
make[3]: Nothing to be done for `all’.
make[3]: Leaving directory `/home/Napisan/unicorn/adsl_status/m4′
Making all in intl
make[3]: Entering directory `/home/Napisan/unicorn/adsl_status/intl’
make[3]: Nothing to be done for `all’.
make[3]: Leaving directory `/home/Napisan/unicorn/adsl_status/intl’
Making all in po
make[3]: Entering directory `/home/Napisan/unicorn/adsl_status/po’
make[3]: Nothing to be done for `all’.
make[3]: Leaving directory `/home/Napisan/unicorn/adsl_status/po’
Making all in src
make[3]: Entering directory `/home/Napisan/unicorn/adsl_status/src’
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../../amu -I../../include/ -I../intl -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -g -O2 -Wall -c main.c
main.c:10:21: error: gtk/gtk.h: No such file or directory
In file included from main.c:12:
interface.h:5: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
In file included from main.c:13:
support.h:44: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
support.h:51: warning: type defaults to ‘int’ in declaration of ‘gchar’
support.h:51: error: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
support.h:59: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
In file included from main.c:14:
status.h:1: error: expected ‘)’ before ‘*’ token
status.h:2: error: expected ‘)’ before ‘*’ token
status.h:3: error: expected ‘)’ before ‘*’ token
status.h:4: error: expected ‘)’ before ‘*’ token
status.h:5: error: expected ‘)’ before ‘*’ token
status.h:6: error: expected ‘)’ before ‘*’ token
main.c: In function ‘main’:
main.c:20: error: ‘GtkWidget’ undeclared (first use in this function)
main.c:20: error: (Each undeclared identifier is reported only once
main.c:20: error: for each function it appears in.)
main.c:20: error: ‘main_window’ undeclared (first use in this function)
main.c:27: warning: implicit declaration of function ‘gtk_set_locale’
main.c:28: warning: implicit declaration of function ‘gtk_init’
main.c:31: warning: implicit declaration of function ‘add_pixmap_directory’
main.c:39: warning: implicit declaration of function ‘create_main_window’
main.c:45: warning: implicit declaration of function ‘create_RxPathLabel’
main.c:45: warning: implicit declaration of function ‘lookup_widget’
main.c:45: warning: implicit declaration of function ‘GTK_WIDGET’
main.c:46: warning: implicit declaration of function ‘create_SNRLabel’
main.c:47: warning: implicit declaration of function ‘create_EchoNoiseLabel’
main.c:49: warning: implicit declaration of function ‘status_init’
main.c:51: warning: implicit declaration of function ‘gtk_widget_show’
main.c:53: warning: implicit declaration of function ‘gtk_main’
make[3]: *** [main.o] Error 1
make[3]: Leaving directory `/home/Napisan/unicorn/adsl_status/src’
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/Napisan/unicorn/adsl_status’
make[1]: *** [all-recursive-am] Error 2
make[1]: Leaving directory `/home/Napisan/unicorn/adsl_status’
make[1]: Entering directory `/home/Napisan/unicorn/unicorntest’
make[1]: Nothing to be done for `all’.
make[1]: Leaving directory `/home/Napisan/unicorn/unicorntest’
make[1]: Entering directory `/home/Napisan/unicorn/tools’
make[1]: Nothing to be done for `all’.
make[1]: Leaving directory `/home/Napisan/unicorn/tools’
for i in libm unicorn_usb ; do make -C $i modules MODDIR=/home/Napisan/unicorn/$i ; done
make[1]: Entering directory `/home/Napisan/unicorn/libm’
make[1]: Nothing to be done for `modules’.
make[1]: Leaving directory `/home/Napisan/unicorn/libm’
make[1]: Entering directory `/home/Napisan/unicorn/unicorn_usb’
make CC=gcc -C /usr/src/linux SUBDIRS=/home/Napisan/unicorn/unicorn_usb modules
make: Entering an unknown directory
make: *** /usr/src/linux: No such file or directory. Stop.
make: Leaving an unknown directory
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/home/Napisan/unicorn/unicorn_usb’
make: *** [modules] Error 2

che mi potete dire?ho installato fedora core 6, non i fa installare il gtk+-devel-1.2.10-33.i386.rpm”. ognio volta m dice che mancano dei pacchetti, ma trovato uno, ne manca sempre qualcun altro.
aiuto!
grazie

52. Avandia. - 21/10/10 @ 9:22

New england journal of medicine avandia….

Fda and avandia….