jump to navigation

Rhythmbox 0.10 + SVN impacchettati per Ubuntu Edgy [deb]

In Articoli, Guide e HowTo, Avanzati, per Guru!, Facili, o quasi :), News e altre Sciccherie il 3/04/07 @ 16:22 , trackback

Chi come me usa Rhythmbox, avrà notato che ieri è stata rilasciata la versione 0.10 per *il* lettore audio di GNOME:

rb010.png

Forse potrà interessare sapere che GetDeb (date un occhio alla nuova veste grafica del sito) ha già impacchettato Rhythmbox 0.10 per Ubuntu Edgy ;)


Per quanto riguarda RB0.10, sappiate che è una versione di “pulizie”, miglioramento e mantenimento del codice: nessuna novità di rilievo e nessuna rivoluzione visibile. Invece se siete alla ricerca di qualche sciccheria posso consigliarvi la versione di sviluppo, che ha ricevuto un po’ d’amore nella barra laterale:

rb010svn-thu.png
La sidebar dell’attuale versione SVN (clicca l’immagine)

Potete installare la versione attualmente in sviluppo scaricandola da svn:

$:  svn co http://svn.gnome.org/svn/rhythmbox/trunk rhythmbox-0.10.0+svn5007

Ovviamente il numero di revisione di svn (5007) potreste dover aggiornarlo in base al numero che viene stampato alla fine dello scaricamento del codice ;)

Per compilarlo e installarlo vi basta seguire le indicazioni sparse nei miei post nella categoria “Compilare con Debian (e Ubuntu)“, e in particolare “Compilare con Ubuntu: 4) Creare pacchetti Debian con dh_make“. Se proprio non avete voglia di compilare e siete disposti ad installare un pacchetto non ufficiale e senza garanzie di funzionamento, vi metto a disposizione quello da me compilato per Ubuntu Edgy :)

Buon ascolto!

PS: ovviamente la mia copia non ha il supporto al fottuto ipod

Pagine forse correlate:

Commenti »

1. NK - 3/04/07 @ 16:31

i’ll try it ;)

2. asdrubale - 3/04/07 @ 16:53

Ma come si fa con Ubuntu Edgy e rhytmbox ad ascoltare gli M4a ?? :(

3. GionX - 3/04/07 @ 16:59

Ciao Felipe,mi potreste cortesemente spiegare come hai fatto per inserire Last.fm sul Rhythmbox mi piacerebbe inserirlo anche io.
Grazie in anticipo.

4. GionX - 3/04/07 @ 17:17

Ciao Felipe,ho già risolto grazie cmq……. ho appena scoperto jamendo O_O che potenza…….

5. linuxiano - 3/04/07 @ 17:18

ciao :D
per favore mi diresti che programma è quello dell’iconcina a forma di busta nella try affianco all’icona di liferea :P

6. Anonymous - 3/04/07 @ 17:44

Arrivato con l’upgrade di feisty

7. kasmol^ - 3/04/07 @ 17:58

cacchio ecco xkè nn mi trasferiva le canzoni nell’ipod kn il tuo pacchetto…ho dovuto rimettere la versione precedente x farlo andare

8. Anonymous - 3/04/07 @ 18:03

Come posso upgradare senza avare 2 copie di rithmbox installate ? (ho già la versione base di edgy su… )

9. UBox - 3/04/07 @ 18:19

Ottimo, anche se non amo molto Rhythmbox, per non dire che non lo amo per niente!:D

10. Anonymous - 3/04/07 @ 18:22

Magari lo sapete già ma per compilare apt ha un tool molto potente per risolvere le dipendenze; “build-dep”.

Esempio:
sudo apt-get build-dep rhythmbox

Ed il gioco è fatto

11. asdrubale - 3/04/07 @ 18:26

ma per leggere gli m4a ? con vlc non c’è problema, ma io vorrei usare rhytmbox !! :(

possibile che nessuno qua sappia nulla ?

12. mighelone - 3/04/07 @ 19:02

@asdrubale
Devi installare i plugin di gstreamer, adesso su Ubuntu non ricordo se siano i “bad” o gli “ugly”, cmq installa tutti i gstreamer0.10-plugin e sei apposto!!!

13. mighelone - 3/04/07 @ 19:03

@asdrubale
gstreamer deve avere il supporto per faac/faad (il codec/decoder GNU per gli mp4)

14. nutellol - 3/04/07 @ 21:27

ho provato a installare il tuo deb ma mi da problemi con la dipendenza da libmusicbrainz >=2.1.4 ma la libreria che riesco a trovare da sorgenti si limita alla 2.1.3
boh? Oo

15. felipe - 3/04/07 @ 21:33

@linuxiano:
Mail Notification Applet: https://pollycoke.net/2006/06/14/mail-notification-applet/

@Anonimo #10:
Se n’è parlato qui: https://pollycoke.net/2006/10/22/compilare-con-ubuntu-1-apt-get-build-dep/

@nutellol:
Puoi soddisfare la dipendenza aggiungendo questo repo
deb http://users.musicbrainz.org/~luks/ubuntu edgy musicbrainz

16. cr7 - 3/04/07 @ 21:33

Deus gratias, delle icone decenti!

17. felipe - 3/04/07 @ 21:34

@cr7:
Decenti dici? A me se devo essere sincero non soddisfano molto… il contrasto delle frecce con il colore dello sfondo di Clearlooks è veramente basso :/

18. cr7 - 3/04/07 @ 21:34

*Deus gratia (lol ho scritto una s di troppo)

19. felipe - 3/04/07 @ 21:36

@cr7:
Chiediamo di gareggiare per il guinnes dei primati in “commento sincronizzato?” :D

20. cr7 - 3/04/07 @ 21:36

>Decenti dici? A me se devo essere sincero non soddisfano molto… il contrasto delle frecce >con il colore dello sfondo di Clearlooks è veramente basso :/
Beh, decenti paragonate all’orrore della versione attuale!

21. cr7 - 3/04/07 @ 21:37

>Chiediamo di gareggiare per il guinnes dei primati in “commento sincronizzato?” :D

LOL :D

22. asdrubale - 3/04/07 @ 22:42

@mighelone

tutti i plugin di gstream sono installati ed in teoria anche il suppoorto per faac (plugin gstreamer-bad e gstreamer-bad-multiverse).

ma nulla da fare gli m4a su ubuntu edgy e con i player che fanno uso di gstream non si leggono !!!

grrrr sempre questi supporti aprossimativi per i formati multimediali !!!!!!! finchè sarà così linux avrà un bel po’ da attendere per diffondersi per bene :(

peccato veramente peccato

23. kasmol^ - 4/04/07 @ 1:44

io prima usavo quod libet, xkè molto leggero, ma ora sto usando rhythmbox ed è ancora + leggero, poi ha il supporto x l’ipod, si scaricano automaticamente le copertine, i testi delle canzoni, devo dire ke x me è veramente perfetto!

24. luponero - 4/04/07 @ 3:16

non capisco perchè ma a me crasha ogni volta che faccio play che posso fare ho provato a reinstallare una tua versione precedente gdeb mi dice che ce ne è una + nuova come posso tornare alla precedente?

25. Anonymous - 4/04/07 @ 10:05

>ma nulla da fare gli m4a su ubuntu edgy e con i player che fanno
>uso di gstream non si leggono !!!
>grrrr sempre questi supporti aprossimativi per i formati multimediali !!!!!!! >finchè sarà così linux avrà un bel po’ da attendere per diffondersi per bene :(

Qui Arch Linux, nessun problema con nessun formato :)

26. cr7 - 4/04/07 @ 10:06

Scusate, il messaggio di sopra è mio :)

27. Winze - 4/04/07 @ 10:07

ma il “coso” per last.fm è solo un player per la radio o fa anche lo scrobbling?

28. Iroquis` - 4/04/07 @ 13:36

Basta che vai su Plugin e inserisci i tuoi dati (cosa che io facevo già dalla dapper)

29. mighelone - 4/04/07 @ 15:51

@asdrubale
controlla con
# dpkg -L gstreamer0.10-plugins-bad |grep faac
se ti da qualche risultato (per tutti questi pacchetti)

oppure

ls /usr/lib/gstreamer-0.10/ |grep faac

per vedere se sono installati, adesso non ho Ubuntu installato quindi non ti so dire con precisione :-(

30. mighelone - 4/04/07 @ 15:55

@asdrubale
I plugin per faac/faad dovrebbero trovarsi nel questo pacchetto gstreamer0.10-plugins-bad-multiverse
http://www.nabble.com/Re:-Gstreamer-plugin-issues-p6410698.html

e quindi devi attivare i repository multiverse (qui spiega come fare
https://help.ubuntu.com/community/Repositories/Ubuntu#head-5bbef89639d9a7d93fe38f6356dc17847d373096)

Ciao

31. asdrubale - 4/04/07 @ 15:56

ls /usr/lib/gstreamer-0.10/ |grep faac
libgstfaac.so

ma nulla da fare :(

32. Winze - 5/04/07 @ 1:06

@Iroquis`:
perfetto! Molto meglio che usare i binari di Audioscrobbler del sito last.fm (anche perchè quello mi bloccava l’audio di Rhythmbox, per cui magari “scrobblava”, ma io non sentivo una cippa…non so perchè). E poi vuoi mettere la bellezza di evitarsi la rottura di palle di aprire due programmi (lo so, questo è scoprire l’acqua calda)…

33. TheDevil - 5/04/07 @ 14:19

Quando compilo Rhythmbox mi da quest’errore:

[email protected]:~/sorgenti/rhythmbox$ ./autogen.sh
/usr/bin/gnome-autogen.sh

checking for autoconf >= 2.53...

testing autoconf2.50...
not found.
testing autoconf...
found 2.60

checking for automake >= 1.7...

testing automake-1.7...
not found.
testing automake-1.8...
not found.
testing automake-1.9...
found 1.9.6

checking for libtool >= 1.5...

testing libtoolize...
found 1.5.22

checking for glib-gettext >= 2.2.0...

testing glib-gettextize...
not found.
***Error***: You must have glib-gettext >= 2.2.0 installed
to build rhythmbox. Download the appropriate package for
from your distribution or get the source tarball at
ftp://ftp.gtk.org/pub/gtk/v2.2/glib-2.2.0.tar.gz

checking for intltool >= 0.30…

testing intltoolize…
found 0.35.0

checking for pkg-config >= 0.14.0…

testing pkg-config…
found 0.20

checking for gtk-doc >= 1.0…

testing gtkdocize…
not found.
***Error***: You must have gtk-doc >= 1.0 installed
to build rhythmbox. Download the appropriate package for
from your distribution or get the source tarball at
http://ftp.gnome.org/pub/GNOME/sources/gtk-doc/

checking for gnome-doc-utils >= 0.4.2…

testing gnome-doc-prepare…
found 0.8.0

checking for gnome-common >= 2.3.0…

testing gnome-doc-common…
found 2.12.0

Checking for required M4 macros…

glib-gettext.m4 not found
gtk-doc.m4 not found

Checking for forbidden M4 macros…

***Error***: some autoconf macros required to build rhythmbox
were not found in your aclocal path, or some forbidden
macros were found. Perhaps you need to adjust your
ACLOCAL_FLAGS?

34. Mister Hahn - 6/04/07 @ 2:22

@ The Devil

sudo apt-get install gtk-doc-tools
sudo apt-get install glib-gettext

Del primo comando sono sicuro, del secondo no perchè io quella macro l’avevo già.

35. Mister Hahn - 6/04/07 @ 2:24

Io ho la “svn5018″… ma anche a voi in “informazioni” dice che la versione è 0.9.8?

Un’altra cosa ragazzi… a voi Last.fm funziona? A me crasha se provo ad usare il plugin Last.fm….

36. TheDevil - 6/04/07 @ 13:36

gtk-doc-tools funzionava, l’altro pacchetto no… Cmq glib2.2.0 l’ho scaricato e l’ho compilato e non mi dice più errore… solo i macros:

Checking for required M4 macros…

glib-gettext.m4 not found

Checking for forbidden M4 macros…

***Error***: some autoconf macros required to build rhythmbox
were not found in your aclocal path, or some forbidden
macros were found. Perhaps you need to adjust your
ACLOCAL_FLAGS?

:( Dove trovo il pacchetto?
L’ho scaricato da qua: http://autoconf-archive.cryp.to/
Ma non va lo stesso :(

37. Mister Hahn - 6/04/07 @ 19:08

Prova con questi due pacchetti:
gettext
gettext-base

Io non credo che ti serva compilare, il pacchetto giusto è già nei repo.. vai a sapere quale però…

38. nicola - 9/04/07 @ 0:47

pollycoke ma tu l’icona per la radio ce l’hai o no ?
ho visto che in uno screenshot c’è e in un altro non c’è.
da me non c’è

39. TheDevil - 10/04/07 @ 14:29

@Mister Hahn: Sono già installati…

Sto maledetto autogen.sh non vuole partire… e sti macros non so manco dove si trovano :(

40. Ferny - 22/04/07 @ 13:19

Non è male rhytm, lo sto utilizzando ora in attesa di trovare Listen aggiornato per feisty.
Ciò che non mi piace:

Graficamente: “Feeling” non molto buono, volete mettere:

http://image.listen-project.org/maxi/webradio.png
La preferisco anche ad amarok (/soprattutto/ ad amarok) ed exaile.
In più: Icone del 15/18, mancanza support OSD, supporto DAAP non “scopribile”, ci dovrebbe essere un qualcosa tipo: Condividi musica con altri utenti che usino $Nomi_client_popolari_compatibili e client compatibili con tecnologia DAAP.
Per l’utenza home ’sta funzione è davvero carina, peccato sia nascosta. Lo stesso dicasi per lo scaricamento dei testi delle song.
Le radio internet non sono “scopribili” (leggi: non c’è l’elenco aggiornato in tempo reale).
Sotto carico alto della CPU le canzoni saltano… Su Listen non l’avevo mai notata ’sta cosa (ed usano lo stesso motore, gstreamer).

41. Andrea - 4/06/07 @ 18:26

@ The Devil

devi installare libglib2.0-dev

Andrea

42. Fred_the_wise - 6/07/07 @ 10:39

mi sembra a posto la tua versione..l’unica cosa “ambigua” son le song lyrics, non funzionano.. provo a compilarle..

43. Edoardo - 24/09/07 @ 21:42

Grande Andrea, finalmente sono riuscito a compilare lopster2 cvs installando libglib2.0-dev grazie

44. Gianni - 16/10/07 @ 13:38

@asdrubale
installa il gstreamer da bad e ugly-multiverse e non avrai problemi.

(commentando accetti implicitamente le Regole di pollycoke, leggile!)