jump to navigation

Aggiornamenti per il repository [pollyrepo]

felipe in: News e altre Sciccherie, Pollycoke Repository, Umorismo spicciolo e... il 24/06/07 @ 21:13 , trackback
0 votes, average: 0 out of 50 votes, average: 0 out of 50 votes, average: 0 out of 50 votes, average: 0 out of 50 votes, average: 0 out of 5 (media: 0, identificati e vota!)
Loading ... Loading ...

- Buonasera, interrompiamo le normali trasmissioni per informarvi che ci sono degli aggiornamenti sul repository, la linea va a felipe.

news.jpg

«Sì, grazie Roma. Effettivamente, come si diceva, ci sono alcuni aggiornamenti che riguardano il repository, che oggi ha ricevuto una bella dose di nuovi pacchetti…»


- Puoi dirci che novità ci sono? Scusa se ti interrompo

«Certo, sono stati aggiornati differenti pacchetti, in particolare Evince, File Roller, Pidgin Extended Preferences, Pidgin Otr, Sound Juicer e infine il GNOME Main Menu che tanto piace ai più giovani»

- Ci era stato segnalato qualche problema con alcuni pacchetti, confermi?

«Assolutamente sì, i pacchetti funzionano tutti bene, ma c’è un problema abbastanza limitante con Evince, che non riconosce i documenti in formato PDF. Essendo pacchetti instabili c’era da aspettarselo prima o poi, inoltre… »

- Si conosce già la causa del problema?

«Al momento gli inquirenti stanno “inquirando” e c’è il più stretto riserbo sulle piste seguite. Qualcuno sospetta di Poppler, che - essendo una libreria - non potrà essere aggiornata nel repository, per via della policy seguita. Sapremo maggiori dettagli nelle prossime ore»

- Capisco, c’è altro?

«Sì, il pacchetto Pidgin Otr non funziona, mancano alcuni simboli nella libreria ma da più parti si invita il pubblico a non abbandonarsi a scene di panico…»

- Grazie, tutto il resto funziona correttamente?

«Sc… scusa non ho sentito bene. Puoi ripetere?»

- Se non ci sono altri avvertimenti ci aggiorniamo in una prossima edizione

«No, non ci sono altri avvertimenti, tranne quello - doveroso - che il repository contiene comunque software instabile, come già più volte ripetuto. Per il resto ho concluso e vi ripasso la linea»

- Bene, è tutto per questa edizione, io vi lascio con il consueto appuntamento del flame su Fedora. A voi tutti una buona sera.

*sigla*

Commenti »

1. andrea - 24/06/07 @ 21:18

sei un grande!

2. L'Uca - 24/06/07 @ 21:18

Mi sembra che il giornalista sia un gran maleducato, ha interrotto Felipe un paio di volte

3. neno - 24/06/07 @ 21:19

come sempre un piacere da leggere, bravo felipe

4. dawlin70 - 24/06/07 @ 21:20

Ribadisco consiglio di cambiare spacciatore

5. Thunder - 24/06/07 @ 21:37

Hhahahahahahahahaha che fulminato XDDD Grande

6. montoya - 24/06/07 @ 21:39

A me piace sw instabile…

7. ciampi - 24/06/07 @ 21:56

felipe capo di stato

8. fabioamd87 - 24/06/07 @ 22:04

LOOL

9. UBox - 24/06/07 @ 22:05

… stai male :)

10. unwiredbrain - 24/06/07 @ 22:05

Feli’, mi stai bacchettando? ;-)

11. Flea - 24/06/07 @ 22:15

STRALOOL!!

12. Flax - 24/06/07 @ 22:19

felipe for president!!!!!!

13. Alberto - 24/06/07 @ 22:24

Mizzeca……..

14. Alberto - 24/06/07 @ 22:25

Mizzeca…….

15. paolo - 24/06/07 @ 22:34

Sei veramente un grande, complimenti. Ma dove lo trovi il tempo e le forze di fare tutto questo? Sembrate un team! Quando sarà che file roller avrà una funzione dipo winzip in cui spostando un file ti chiede se scomnpattarlo in quella cartella?

16. monossido - 24/06/07 @ 22:49

…’sta tv spazzatura… :D:D

17. riva.dani - 24/06/07 @ 22:54

Sempre simpaticissimo felipe, l’unico problema è che forse mi conviene aspettare ad aggiornare, visto che uso esclusivamente Evince per leggere i PDF…

Però ora che posso installarlo con un comodo apt-get install anzichè affidarmi a svn credo sia giunto il momento di provare il GNOME Main Menu. :)

Grazie di tutto, come sempre.

@paolo
Verissimo, sarebbe comodo! Ricordo che le prime volte, data l’abitudine, trascinavo i file direttamente dagli archivi, e quando vedevo che non succedeva niente m’incazzavo pure… Grrr!! :D

18. Fruskio - 24/06/07 @ 23:11

Hahahah sei proprio scemo :-)!

19. Indy - 24/06/07 @ 23:14

Ti citerò per la prima volta nel mio blog. Dal momento che sono un po’ nuovo a queste cose, tuoi eventuali consigli sono ben accetti. (se poi riesco a capire il perverso meccanismo del trackback sono a cavallo…

20. Raideiin - 24/06/07 @ 23:22

ahahahahahahahah! Quanto fa di share il tuo TG? ;)

21. Anonymous - 24/06/07 @ 23:40

38 gradi e vento di scirocco abbastanza *pesante* ? XD

22. Diverremo tutti magrissimi - 24/06/07 @ 23:47

Tutto in un colpo solo

? ormai da un po’ di tempo che mi sono votato ad una nuova religione, quella di linux. Prover? a parlarne, per invogliare qu…

23. ubuntuz - 24/06/07 @ 23:51

Ste idee per scrivere questi post da dove le togli?
comunque ottima idea l’intervista buon lavoro con il repository e continua così! :)

24. Cobra78 - 24/06/07 @ 23:54

Una cosa mi sfugge: perchè mettere online un update che non fa funzionare Evince?
Non lo dico per polemica sia chiaro, ognuno poi è libero di aggiornare o meno, ma non ne capisco il motivo.

25. Anonymous - 24/06/07 @ 23:59

ribadisco che se non si mette su un build daemon con cui modificare gli script (per aggiornamenti , patches, dipendenze , etc … ), il *lavoro* che felipe sta facendo lo farà andare più fuori di testa di quanto non lo sia già :D

26. Marco M. - 25/06/07 @ 0:07

mi chiedo..ma per fare un reposity come il tuo..bisogna creare un server vero?

27. Anonymous - 25/06/07 @ 0:48

bellissimo!! Aggiunto a google reader da stasera!! Troppo forte!!!

28. Matiee - 25/06/07 @ 2:21

@ 6. montoya
Anche a me, 2 palle, sto linux non crasha mai… troppo prevedibile…
Te ne hai mai sentito parlare di quell’altro? Windows, mi pare…
Sembra che sia una figata… :D

29. Anonimo - 25/06/07 @ 7:05

Ma sei matto? Se Evince non funziona allora perche lo hai messo?

30. Lazza - 25/06/07 @ 8:56

Sarei curioso di sapere a cosa può servire Evince se non legge i Pdf. Non è polemica, dico sul serio.

31. Borzo - 25/06/07 @ 9:23

Semplicemente tiene su dei pacchetti che sceglie di includere sempre la versione più aggiornata, è coerenza, niente di più.

Almeno, io penso che sia per questo.

32. felipe - 25/06/07 @ 9:33

@tutti:
Hehe, contento che apprezziate qualche momento di follia -.-

@ma-allora-perché-lo-includi:
Bella domanda… lo lascio a disposizione di chi vuole investigare, e principalmente perché spero di poter risolvere il problema! Se così non fosse conto di riportarlo alla versione precedente al più presto :)

33. [email protected] - 25/06/07 @ 9:48

Bel post :D

Lasci il pacchetto a disposizione di chi vuole investigare?
UOOOOOO UOOOOO UOO DETECTIVE CONAN!

34. Indy - 25/06/07 @ 9:53

Ho avuto una trentina di contatti sul sito solo per aver scritto quelle due cosine precedenti.
Il fatto è che iniziavano con “ti citerò…”! Io intendevo solo dire che sarai menzionato, non volevo attirare l’attenzione dicendo che ti citerò in giudizio!!!!!! :D

35. frank95com - 25/06/07 @ 10:12

Sto provando a compilare poppler dai sorgenti di gutsy e poi faccio l’aggiornamento. Dopo provo e vi dico com’è andata.:D

36. .:FireFox:. - 25/06/07 @ 10:38

Scusa felipe che c’è di nuovo nel pacchetto GNOMe main menù?Grazie

37. frank95com - 25/06/07 @ 11:48

Allora…. ho compilato poppler e gnome-pkg-tools dai sorgenti di gutsy.
Poi ho dovuto ricompilare the gimp per adattarsi alle nuove librerie che hanno cambiato nome (da libpoppler1-glib a libpoppler-glib1 chissà perché) alla fine ho ricompilato anche evince dai repository di gutsy.
Dopo averlo compilato mi ha chiesto ghostscript-x allora ho compilato anche quello.
Alla fine ho potuto installare evince e sono riuscito ad aprire i pdf. :D

1 ora di compilazione=93° di CPU.

Tutto è bene quel che finisce bene anche se adesso la mia Ubuntu si chiama Gusty Fawn o Feisty Gibbon. :D

38. felipe - 25/06/07 @ 12:08

@tutti:
La situazione Evince è la seguente: il supporto PDF dipende - come immaginavo - da una versione più recente della libreria Poppler. Non ho alcuna intenzione di impacchettare librerie nel mio repository, come scritto fino alla nausea, quindi niente Evince.

Adesso riporto Evince alla versione 0.8.1 con un trucchetto (spesso usato dai dev Debian) per farla comparire come avanzamento. Per installarla vi basterà quindi aggiornare come se niente fosse, e avrete la versione originale di Feisty funzionante come al solito.

Mi spiace per qualche eventuale disagio :)

PS: frank95com adesso capisci uno dei motivi per cui è meglio non impacchettare librerie?

39. risidoro - 25/06/07 @ 12:31

Grazie ancora una volta per questi pacchetti felipe. Solo una domanda: che senso aveva pubblicare evince se già sapevi che non funzionava con i pdf? Capisco che il repository è instabile, ma se uno già sa che la funzione principale di un pacchetto non funziona, si risparmia la fatica e non lo pubblica, no?
Cmq, grazie per la correzione extrarapida e per tutto il lavoro fatto.
Ciao!

40. stambec92 - 25/06/07 @ 12:37

‘Sto gnome main menu cos’è? Una roba tipo affinity?

41. frank95com - 25/06/07 @ 13:00

@ risidoro: per la verità all’inizio c’era la possibilità che qualcuno potesse trovare una soluzione al problema senza dover compilare librerie extra ma purtroppo queste sono indispensabili e quindi non c’è soluzione se non compilare le librerie nuove, che però portano dei problemi con alcuni software.

@ felipe: certo, infatti se per installare una versione più recente di un programma bisogna fare tutto sto lavoro è meglio aspettare :D Cmq grazie per gli altri aggiornamenti che funziano alla grande.

42. lerrigatto - 25/06/07 @ 14:26

Indubbiamente il caldo fa molto, molto male alla gente…
Prova a rinfrescarti con un po’ di pollycoke xd

Si, il caldo fa male…

43. Raldo - 25/06/07 @ 20:15

Pidgin otr ha introdotto alcuni simboli astrusi che xorg non riconosce, bloccando qualsiasi programma grafico. :) Ti Odio, ho un 56 kb, e devo con wvdial, quindi ad 1 kbs per il mio conexant, scaricare 600 mb di xorg e gnome. :)

44. franganghi - 25/06/07 @ 20:54

Ma su emule si trovano le edizioni precedenti del Lipegiornale?

45. Giuseppe - 25/06/07 @ 21:51

Wow

46. joevanni99 - 25/06/07 @ 23:03

Ciao Pollycokers…1 problema…volevo aggiornare, ma synaptic mi restituisce questo errore: “L’indice del software è rovinato

Impossibile installare o rimuovere alcun software. Utilizzare il gestore dei pacchetti «Synaptic» o eseguire «sudo apt-get install -f» in un terminale per correggere innanzitutto questo problema.”

se do il comando indicato, ottengo invece questo…

dpkg: errore processando /var/cache/apt/archives/tracker_0.5.4-4_i386.deb (–unpack):
tentata sovrascrittura di `/usr/share/locale/de/LC_MESSAGES/tracker.mo’, che si trova anche nel pacchetto tracker-data
dpkg-deb: il sottoprocesso paste è stato terminato dal segnale (Pipe interrotta)
Sono occorsi degli errori processando:
/var/cache/apt/archives/tracker_0.5.4-4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

che fare?

47. Federico, A. Moretti - 25/06/07 @ 23:37

Ahahaha… bellissimo… :)

48. kr0n1x - 30/06/07 @ 8:16

io continuo ad avere problemi…
finché era solo evince niente problemi..
il fatto è che finché c’è sto “baco”..non riesco a installare gli altri aggiornamenti:(
ho provato a commentare il repo felipe..(il tuo intendo) ma poi mi ritrovo con altri problemi:(
puoi consigliare come risolvere momentaneamente il problema? (escludendo la soluzione dell’attesa si intende..)
devo rimuovere tutti i pacchetti ~pollycoke e poi commentare il tuo repo? forse è per questo che avevo problemi poi anche commentandolo?
fammi sapere per favore:S mi sento su windows xp che non posso mettere gli aggiornamenti :D aasdasdas
grazie ciao!

49. kr0n1x - 1/07/07 @ 16:41

@felipe: ho scritto anche sul forum di ubuntu, con più info: http://forum.ubuntu-it.org/index.php?topic=99189.0

per favore aiutami che non riesco più a utilizzare ubuntu :(

(commentando accetti implicitamente le Regole di pollycoke, leggile!)