jump to navigation

Firefox 3.0 in anteprima per Ubuntu Hardy [repo]

In News il 11/06/08 @ 1:31 trackback

Firefox 3.0 anteprima - Pollycoke :)

Chicca! Anche se manca presumibilmente un po’ al rilascio ufficiale, gli utenti di Ubuntu Hardy possono provare la brezza l’ebbrezza di usare Firefox 3.0 in leggera anteprima. Stavo per compilarlo io (già completato xulrunner) quando per puro caso mi sono accorto che i pacchetti ufficiali sono appena entrati nel repository “hardy-proposed”.

Beh quando è così mi sa che risparmio un po’ di cicli di CPU e se qualcosa va storto possiamo agevolmente dare la colpa agli altri :D Per installare “il miglior browser in circolazione” (cit self) vi basta dunque aggiungere queste righe al vostro sources.list, potete farlo anche tramite Synaptic:

deb http://archive.ubuntu.com/ubuntu/ hardy-proposed restricted main multiverse universe

Sappiate che i repo “-proposed” di Ubuntu sono dei depositi di sotware in prova prima di poter essere ammessi ai repo di backport. Tenetelo a mente se avete qualche dubbio, in tal caso vi conviene aspettare che facciano tutti i test di rito. Io devo dire che lo sto usando da una mezz’ora e non ho alcun problema.

Ci vorrà forse un po’ prima che tutte le estensioni più comuni vengano supportate, ma se avete già cominciato ad usare Firefox dalle prime beta o con il mio pacchetto di “Firefox 3 RC1 per Ubuntu Hardy [pollyrepo]” sapete già a cosa andare incontro ;-) Se non doveste trovare la traduzione italiana automaticamente installata potete cliccare qui e riavere il vostro Firefox in italiano (grazie Giacomo!).

Buona navigazione e segnalate pure le vostre impressioni, se ne avete…


Pagine forse correlate:

Etichette: , ,

Commenti »

1. Lanz - 11/06/08 @ 1:44

Wow … stavolta sono stati velocissimi … ero incredulo quando ho visto l’aggiornamento da synaptic … O_O

2. Aenima - 11/06/08 @ 1:54

Grazie mille della segnalazione!!! Proprio quello che cercavo…

P.S= C’e’ un errore nell’indirizzo dei repository : "multiverseuniverse" tuttattaccato!

3. Altro che Guinness World Records: Firefox 3 è [già] su Ubuntu/Hardy at brand:GNU² - 11/06/08 @ 2:23

[...] evidente che non stavo “sognando” (a causa del doppio aperitivo): nonostante gli sforzi della Mozilla Foundation per stabilire un [...]

4. Sincronizziamoci - 11/06/08 @ 7:47

Una release perfettamente sincronizzata con OpenSuse 11.

Coincidenza?

5. Gondor - 11/06/08 @ 8:30

Per risolvere il problema delle estensioni basta modificare una voce in un file.
I file .xpi non sono altro che zip rinominati. Scompattate l’estensione; aprite il file install.rdf; al tag "","" (senza virgolette) inserite "3.*" (senza virgolette) al posto del vecchio valore; ricompattate i file con il comando zip e rinominate il file creato eliminando l’estensione .zip.

Con File Roller su GNOME è ancora più semplice: basta aprire l’estensione, cliccare due volte sul file "install.rdf"; usare gedit per modificarlo; salvare la modifica e dare la conferma di aggiornamento al file richiesta da File Roller.

6. Guada - 11/06/08 @ 9:15

@Gondor

Mah insomma insomma… Io ho provato la stessa cosa con la Google Toolbar, ma mi da un sacco di problemi, penso che il problema delle estensioni non sia così triviale come sembri =)

7. DnaX - 11/06/08 @ 10:27

@Gondor: Beh fai conto che se alcune estensioni posso anche funzionare altre saranno molto instabili o non funzioneranno del tutto! Hanno fatto molte modifiche anche al modo di esportare le funzioni di Firefox3 per le estensioni…

8. Shiba - 11/06/08 @ 10:41

Io sono su una Ubuntu 64, e fossi in voi non attiverei i repo proposed in quanto hanno una versione di openoffice (2.4.1rc2) che non fa altro che dare problemi.

9. vola - 11/06/08 @ 10:57

@gondor: se installi cosi le estensioni taroccando la versione non è detto che poi funzionino correttamente. E’ meglio aspettare che ufficialmente sia rilasciata la versione ufficiale compatibile.

10. LordKhain - 11/06/08 @ 11:45

@4. Sincronizziamoci:

Spero proprio che sia una coincidenza, visto che le politiche di rilascio di SuSE sono patetiche. Sarò strano ma a me piace che il sistema funzioni…

11. incuso - 11/06/08 @ 11:58

Normale che "about:" mi mostri 1.9 come versione?

12. Damiano - 11/06/08 @ 12:42

@Shiba: il bug di openoffice che toglieva i file di localizzazione è risolto da un po’, ormai… era solo un problema di dipendenze dei file di localizzazione stessi.
Ubuntu amd64 con hardy-proposed attivo senza alcun problema!

13. furester - 11/06/08 @ 12:43

siam sicuri che non sia l’rc2? ho compilato l’rc2 qualche giorno fa e anche a me segna come versione la 3.0 andando su "about" .. eppoi .. nn vogliamo dare una mano alla mozilla foundation ad entrare nel guinness? aspettiamo il download day e scarichiamo da loro tutti insieme!

maggiori info qui: http://www.spreadfirefox.com/en-US/worldrecord/

14. orion91 - 11/06/08 @ 13:25

Felipe siamo sicuri che sia proprio così: "..Sappiate che i repo “-proposed” di Ubuntu sono dei depositi di sotware in prova prima di poter essere ammessi ai repo di backport.." ?
Io pensavo che gli aggiornamenti hardy-proposed finissero nei repo normali e non quelli backports che dovrebbero essere tenuti dalla community.. ho sempre capito male io oppure hai scritto male te (insomma un piccolo errore di distrazione)? Se qualcuno magari mi aiuta a capire bene questa cosa, grazie.

15. felipe - 11/06/08 @ 13:51

@Aenima:
Grazie, sistemato :)

@Gondor:
Già ma quella procedura frega solo il controllo di versione, va detto che se ci sono incompatibilità reali non basta

@incuso:
Xulrunner è alla versione 1.9, quindi sì, è normale :)

@furester:
È appunto una versione di anteprima, ma non so se chiamarla rc2. Il pacchetto riporta 3.0 e probabilmente si tratta di una via di mezzo.

@orion91:
In realtà volevo scrivere “updates” al posto di “backports”, ma adesso che mi ci hai fatto pensare non mi sento più tanto sicuro.

16. said - 11/06/08 @ 17:13

ma solo io riscontro ancora il bug sulle checkbox o veramente non l’hanno ancora corretto?!