jump to navigation

KDE 4 per Ubuntu Gutsy, in un paio di ore ;)

felipe in: Articoli, Guide e HowTo, Avanzati, per Guru!, Facili, o quasi :) il 23/10/07 @ 14:33 , trackback
4 votes, average: 5 out of 54 votes, average: 5 out of 54 votes, average: 5 out of 54 votes, average: 5 out of 54 votes, average: 5 out of 5 (media: 5, identificati e vota!)
Loading ... Loading ...

Attenzione: ho scritto una nuova versione di questa guida, ottimizzata per Ubuntu 5.04 “Hardy Heron”: KDE 4.1 per Ubuntu Hardy, in un paio di ore ;) Seguite quella!

kde400.jpg
E continua a crescere… :)

12/05/08: aggiornata la guida per usare le Qt 4.4 precompilate di Ubuntu Hardy
15/02/08: aggiornata la guida per il passaggio di KDE a Qt 4.4 :)
15/02/08: avverto che è stata rilasciata una nuova versione di kdesvn-build.
24/01/08: libpcre3-dev dipendenza di compilazione (grazie montag!)
14/01/08:
kdesvn-build deve andare in /usr/bin! (grazie Matteo!)
11/01/08: aggiunto un paragrafo per indicare come eliminare KDE4
05/01/08: sistemato il file di config, recuperatelo di nuovo e aggiornate!
05/01/08: spostato il file kdesvn-buildrc su pollycoke.net (tuxfamily irraggiungibile)
04/01/08: modificato il file di configurazione per installare KDE 4 in italiano! ;)
10/11/07: aggiunto un controllo per selezionare la giusta versione di qmake
10/11/07: eliminata la localizzazione italiana (restituisce ancora errore) dal kdesvn-buildrc fornito
10/11/07: esplicitata la necessità di dover dare il permesso di esecuzione a kdesvn-start
09/11/07: sistemato il paragrafo “Prerequisiti” per risolvere alcuni problemi con gli ultimi aggiornamenti
29/10/07: corretta una svista nel file kde4.desktop (grazie myway!)
29/10/07: convertita la guida per installare tutto in /opt invece che in $HOME
29/10/07: eliminata la modifica ad /etc/sudoers
29/10/07: aggiunte le istruzioni per lanciare la sessione KDE4 da GDM/KDM
28/10/07: link alla traduzione italiana delle istruzioni avanzate, a cura di Thunder Teaser

Me lo avete chiesto in tanti, talmente tanti che mi sono auto-costretto a razionalizzare un sistema per compilare KDE4 in maniera semi-automatica. Ecco dunque quello che ritengo il metodo più veloce e semplice per avere una copia di KDE 4 sempre aggiornata sulla vostra scrivania.

Ho cominciato a compilare KDE4 da prima del rilascio della terza beta (cfr “KDE 4 appena compilato…“), e in questo tempo ho continuato ad aggiornare e sperimentare un po’ di metodi; posso dire di avere un’idea su cosa consigliare a chi non vuole stare troppo appresso ai dettagli, così come a chi invece preferisce avere il pieno controllo di tutto il processo.

Avvertenza: nel post “Per chi ha problemi a compilare KDE 4 in questi giorni” ho raccolto tutta una serie di errori comuni o piccoli non-problemi di compilazione, dopo aver seguito attentamente questa guida (che resta valida) se doveste avere problemi fate riferimento a quella

C’è una procedura per i più esperti…

Se sapete compilare e non vi spaventa mettere le mani nelle budella della vostra Ubuntu, o in qualsiasi sia la vostra distribuzione, sappiate che KDE techbase ha delle ottime istruzioni per compilare KDE 4 (in inglese) in modo “manuale”.

Sono le istruzioni che ho seguito io all’inizio e devo dire che funzionano bene e allo stesso tempo mettono in condizione di capire ogni passo di cosa si sta facendo. Insomma sono consigliate per chi considera divertente la compilazione in sé, pur se devo dire che ci sono alcune contraddizioni… es. io ho scelto di fare tutto da unico utente, ma la guida accenna confusamente alla possibilità di fare tutto con un’altro utente.

Aggiornamento: come segnalato da lui stesso nel commento #85, Thunder Teaser (grazie!) ci ha fatto un bel regalo e ha tradotto l’intera pagina con le istruzioni in italiano :)

…e una per i novellini (ma non solo)

Come segnalato da Treviño nei commenti al post citato in apertura, esiste uno script preparato dal team di KDE, pensato proprio per rendere agevole e rapida l’installazione da svn. Funziona sia per KDE3 che per KDE4, anche se a noi interessa solo l’ultimo, ovviamente.

1. Presequisiti

La prima cosa da fare è installare tutte le dipendenze di compilazione per KDE4, per lo meno i moduli base, che per Ubuntu Gutsy sono:

$:  sudo aptitude install build-essential cdbs debhelper cmake libxml2-dev \
libxslt1-dev libbz2-dev librdf-dev shared-mime-info dbus-x11 libxkbfile-dev \
libgl1-mesa-dev libglu1-mesa-dev mesa-common-dev libxext-dev libjpeg-dev \
libpng-dev subversion libsm-dev libxinerama-dev libxrender-dev libfontconfig-dev \
libboost-dev libxcursor-dev doxygen libungif4-dev libdbus-1-dev libgpgme11-dev \
libssl-dev libgpgme11-dev libasound2-dev kdesdk-scripts libpth-dev libjasper-dev \
ssh libxine-dev libglib2.0-dev libpcre3-dev libexpat-ocaml-dev

Ok, è un bel po’ di roba, ma probabilmente alcuni di questi pacchetti li avete già installati se vi capita di compilare ogni tanto, e poi sappiate che installando questi si evita di compilare inutilmente alcune dipendenze pesantissime (come le Qt!) che nella versione di Ubuntu Gutsy sono già sufficientemente aggiornate.

Se avete seguito questa guida in precedenza sappiate che ci sono stati alcuni recenti cambiamenti in KDE Base, e che alcune dipendenze che prima consigliavo di installare devono essere rimosse. Per fare ciò date questo comando. Se volete compilare KDE 4 fatelo in ogni caso, non può fare alcun danno:

$: sudo aptitude remove libcluceneindex0 libclucene-dev libclucene0 libeigen-dev \
libqca2 libqca2-dev libqimageblitz-dev libqimageblitz4 libsoprano-dev libsoprano4 \
libstreamanalyzer-dev libstreamanalyzer0 libstreams-dev libstreams0 \
libstrigiqtdbusclient-dev libstrigiqtdbusclient0 libqca1c2 qca-dev

Una volta sistemata la parte relativa alle dipendenze bisogna scaricare una copia dello script kdesvn-build. Dopo aver scompattato l’archivio in cui è distribuito avremo sostanzialmente l’eseguibile “kdesvn-build“, un paio di file di configurazione d’esempio e vari altri file di documentazione. A voi interessa solo l’eseguibile, dal momento che al file di configurazione per Ubuntu Gutsy ci ha pensato il vostro affezionatissimo.

Una cosa molto importante da controllare è che la versione di qmake in uso dal sistema sia quella necessaria a compilare KDE 4, e cioè la 4 appunto. Per fare questo bisogna usare il comando:

$: sudo update-alternatives --config qmake

Molto probabilmente questo vi mostrerà (contrassegnandola con un asterisco) che la versione in uso è qmake-qt3. Per cambiare a qmake-qt4 è sufficiente digitare il numero corrispondente alla riga di qmake-qt4 e premere Invio.

2. Il file di configurazione di kdesvn-build (e altri dettagli)

Potete scaricare questo file di configurazione per kdesvn-build da me semplificato e ottimizzato per Ubuntu Gutsy o equivalenti. Dovrete rinominarlo “.kdesvn-buildrc” (occhio al punto iniziale) e posizionarlo nella vostra home, oppure potete anche solo prendere spunto dal mio per personalizzare quello originale, che oltre tutto è anche molto ben commentato.

Utilizzando il mio file di configurazione avrete le seguenti impostazioni:

3. Si comincia

Spostate l’eseguibile kdesvn-build nella directory /usr/bin, sovrascrivendo la vecchia versione installata con il pacchetto “kdesdk-scripts“, e sarete già pronti a cominciare. Per avviare la procedura che installerà sostanzialmente le librerie e le applicazioni base di KDE vi basta lanciare il comando:

$: sudo kdesvn-build

Questo si prenderà cura di scaricare, aggiornare, compilare, installare i moduli kdesupport, kdelibs, kdepimlibs e kdebase, che sono quelli sufficienti ad avere un’installazione minima del desktop (Plasma) e con applicazioni come Kwrite, Konqueror, Dolphin…

Nel mio PC che fa assolutamente pena (AMD Sempron 2800+, 1GB RAM) l’intera operazione dura circa un paio d’ore, quarto d’ora più o meno. Una delle cose carine è che lo script ci ricorda nell’estetica (ma purtroppo non nel funzionamento) l’indimenticabile emerge di gentoo, soprattutto per le preziose informazioni che mostra, e nel modo in cui le formatta:

kdesvn-build.jpg
Il risultato del comando: “kdesvn-build kdenetwork”

Come vedete basta mezz’ora circa per compilare KDE Network (kopete, kget, krdc, kpp…). Per installare moduli aggiuntivi, come appunto kdenetwork, basta lanciare kdesvn-build seguito dal nome del modulo desiderato. Volete provare ad esempio Okular e Gwenview? Vi basta installare kdegraphics:

$: sudo kdesvn-build kdegraphics

Non vedete l’ora di testare il nuovo Kmail? Ecco:

$: sudo kdesvn-build kdepim

I nomi di tutti gli altri moduli li trovate nel file di configurazione, o meglio ancora: nell’interfaccia web al repository svn di KDE. Funzionano anche i “sotto moduli”, come ad esempio:

$: sudo kdesvn-build  extragear/multimedia/amarok/

…per avere Amarok2. Lo so che stavate tutti aspettando questo comando :D

kdesvn-build-amarok.jpg

Per la cronaca, per installare Amarok avrete bisogno del pacchetto ruby1.8-dev installato. Per capire quali dipendenze vi mancano per installare questo o quel modulo potete comodamente fare affidamento ai poteri della supermucca, ad esempio per kdenetwork:

$: sudo apt-get build-dep kde4network

Ma evitate di installare anche kdelibs* e simili, quelli li avete già anche se ovviamente APT non ne sa niente ;)

Ultima chicca: se non volete compilare di nuovo da capo, ad esempio se al 90% la compilazione di kdebase si blocca perché vi manca una dipendenza, potete usare un parametro ad hoc:

$: sudo kdesvn-build --reconfigure kdebase

Questo eviterà di dare il “make clean” iniziale, per cui continuerete a compilare da dove vi eravate interrotti. Da usare con cautela e cognizione di causa: se non riuscite più a compilare un modulo nonostante abbiate soddisfatto qualsiasi dipendenza immaginabile probabilmente è arrivato il momento di eliminare il parametro dalla linea di comando ;)

4. Avviare il KDE 4 nuovo di zecca

La prima cosa che torna utile è questo mini-script che serve a lanciare KDE4 con un unico comando. Copiate queste righe nel vostro editor preferito (Gedit, Kwrite, ecc):

export QTDIR=/opt/qt4
export KDEDIR=/opt/kde4
export KDEHOME=$HOME/.kde4
export LD_LIBRARY_PATH=$KDEDIR/lib:$LD_LIBRARY_PATH
export PATH=$QTDIR/bin:$KDEDIR/bin:/usr/local/bin:$PATH
startkde

Salvate il file così creato come “kdesvn-start”, spostatelo in /usr/local/bin e dategli i permessi d’esecuzione, così:

$: sudo chmod +x /usr/local/bin/kdesvn-start

Adesso potete usare quello script per lanciare un’intera sessione KDE4, basta creare un file di sessione kde4.desktop e schiaffarlo in /usr/share/xsessions. Ecco il contenuto del nuovo file:

[Desktop Entry]
Encoding=UTF-8
Type=XSession
Exec=/usr/local/bin/kdesvn-start
TryExec=/usr/local/bin/kdesvn-start
Name=KDE4
Comment=The K Desktop Environment

La prossima volta che avvierete il PC, tra le opzioni di scelta di sessione in GDM/KDM troverete anche KDE4 :)

5. Eliminare KDE 4

Potreste trovarvi nella situazione di voler eliminare KDE4, magari per installare i pacchetti precompilati forniti da Kubuntu (cfr “KDE 4 per Ubuntu Gutsy, in dieci minuti ;)“), certamente più comodo che compilare. Per eliminare ogni traccia di KDE 4 compilato grazie a questa guida basta dare i seguenti comandi:

$: sudo rm -rf /usr/src/kde4
$: sudo rm -rf /opt/qt4
$: sudo rm -rf /opt/kde4
$: sudo rm -rf /usr/local/bin/kdesvn-start

E magari potremmo eliminare anche la configurazione utente:

$: rm -rf ~/.kde4

A questo punto avrete ripulito per bene qualsiasi traccia :)

6. Conclusioni

Commenti e miglioramenti per rendere ancora più semplice la guida sono ben accetti. L’importante è che tutti siate coscienti che quello che si può installare al momento è solo un’anteprima di ciò che sarà KDE4. Pertanto è ancora instabile, non è detto che compili sempre, a volte risulta lento e in generale capirete che è codice allo stato di Beta :)

Buona esplorazione dunque, ogni giorno spuntano delle piccole novità e senza rendervene conto vi troverete a tenere d’occhio gli aggiornamenti in svn, a caccia di qualche modifica interessante. Come ho già detto: è molto bello assistere alla crescita di questo KDE4 “in diretta“, lo considero un tributo al grandioso impegno profuso ogni giorno dal generoso team di sviluppo.

Ogni ringraziamento va idealmente a loro.

Commenti »

1. Ecas - 23/10/07 @ 14:46

Bravo complimenti per l’iniziativa e per lo sbattimento :)

2. sarbyn - 23/10/07 @ 14:49

Domanda stupida, ma importante nel mio caso.

Tutta questa procedura quanto spazio mi richiede su disco? :)

3. felipe - 23/10/07 @ 14:54

@Ecas:
Grazie caro :D

@sarbyn:
Con i moduli: kdelibs, kdepimlibs, kdebase, kdegraphics, kdenetwork, amarok,
[email protected]:~$ du -sh kde
250M kde
[email protected]:~$ du -sh src/kde4/
1,4G src/kde4/

Se si installa solo il sistema base è ovviamente meno ;)

4. piivi - 23/10/07 @ 15:04

Una domanda felipe: come si fas a compilare nempomukdaemon? e raptor?

Questo è l’output per raptor.. dove sbaglio?

kdesvn-build playground/base/raptor
Script started processing at Tue Oct 23 14:00:20 2007
<<>>

Updating playground/base
Updating raptor

<<>>

<<>>
playground/base - ~/kdesvn/log/2007-10-23-11/playground/base/svn-up-raptor.log
Script finished processing at Tue Oct 23 14:00:31 2007
Your logs are saved in /home/pv/kdesvn/log/2007-10-23-11

5. piivi - 23/10/07 @ 15:09

come non detto, forse era un problema temporaneo.. l’ha compilato!
provo cn nepomuk ora

6. Andrey - 23/10/07 @ 15:11

@felipe
io avevo provato a installare KDE4 seguendo la guida di kubuntu ma quando scelgo la sessione kde4 da kdm parte la splashscreen e poi torna a kdm..hai qualche idea? se dovessi seguire la tua procedura cosa devo rimuovere? Grazie

7. felipe - 23/10/07 @ 15:11

come non detto :)

8. Linux - Fueled - 23/10/07 @ 15:11

ottima guida, gran lavoro grazie :)

9. piivi - 23/10/07 @ 15:18

@andrey guarda sul blog di tuxmind, c’è la guida con la correzione

@felipe.. niente da fare con nepomuk, nel readme di nepomuk-kde in playground/base/nepomuk-kde c’è scritto:

“The core Nepomuk-KDE components have been moved to kdelibs and kdebase”

purtroppo però quando lancio kde4 nepomuk non è attivo e non c’è nessun nepomukdaemon da lanciare…

10. spupuz - 23/10/07 @ 15:19

gnome forever :P

11. marco - 23/10/07 @ 15:26

Requiem per i poveri gnomisti come me, per cui non c’è più trippa per gatti :(

12. yattamax - 23/10/07 @ 15:28

per il momento KD4 è veramente orrendo da vedere …. se questi sono i presupposti, per me può anche rimanere dov’è.

gusti personali … per carità :)

13. Michele Renda - 23/10/07 @ 15:28

anche se non l’usero mai, bel lavoro

14. Thunder - 23/10/07 @ 15:37

KDE è tutta un’altra cosa. Finalmente non è più quell’ammasso inguardabile di cornici e robe stucchevoli che ti faceva passare la voglia di usarlo. PS: complimenti per il lavoro felipe :)

15. Xander - 23/10/07 @ 15:42

@ marco: al momento non mi pare si possa parlare di qualcosa di usabile quotidianamente. Aspettiamo almeno l’uscita di KDE4 (magari anche la 4.1..) prima del Requiem per Gnome..
;)

16. felipe - 23/10/07 @ 15:47

@tutti:
Vorrei molto pacatamente chiedere il favore ad alcuni di voi di NON tirare fuori GNOME in post che non lo riguardano per niente.

Raramente ho visto succedere il contrario nei post dedicati a GNOME, almeno qui su pollycoke :) e quando è successo mi sono subito espresso in maniera negativa. Amo GNOME e mi piace esattamente come sempre, ma se scrivo di qualcosa è davvero scocciante vedere spuntare fuori commenti su tutt’altro.

Grazie tante per la collaborazione

17. Claudio - 23/10/07 @ 15:50

@tutti gli gnomisti
il problema non è cosa fa kde, ma cosa farà gnome?
Ci metterà i soliti anni per recuperare?

18. Vide - 23/10/07 @ 15:50

@andrey: hai installato kde4base-dev come dice su kubuntu.org ? Anche se sembra inutile, a me senza installarlo si piantava esattamente come nel tuo caso, dopo averlo installato ha funzionato egregiamente

19. khelidan - 23/10/07 @ 15:53

“Una delle cose carine è che lo script ci ricorda nell’estetica (ma purtroppo non nel funzionamento) l’indimenticabile emerge di gentoo”

Allora non è stata solo una mia impressione….è stata la prima cosa a cui ho pensato appena ho vistto l’immagine!! :)

20. Xander - 23/10/07 @ 15:57

Scusate l’OT, non c’era nessuna intenzione di flammare, bensì solo di rispondere.

Lunga vita a tutti i DE..

Saluti.

21. .:FireFox:. - 23/10/07 @ 15:59

Scusa felipe io ho gia installato kde4 da synaptic alla beta3 ma per esempio mi manca il kickoff e amarok ecc…posso usare kdesvn-build per aggiornare il tutto o devo aspettare l’aggiornamento dei repo?

22. Anonymous - 23/10/07 @ 16:05

prot.png? :D

23. Michele C.S. - 23/10/07 @ 16:12

Invece di modificare il sudoers non conviene avviare un terminale e andare di “sudo su”?

24. roboticalmind - 23/10/07 @ 16:13

grazie mille :D :D :D
era da tempo che volevo installare KDE4 da svn, ma la procedura lunga e laboriosa mi aveva sempre scoraggiato…
ancora grazie ;)

25. Installiamo KDE 4 dal repository « Daniele’s blog - 23/10/07 @ 16:38

[...] il sempre prolifico Felipe, ha creato una guida davvero semplice da seguire per compilare tutto il [...]

26. ziabice - 23/10/07 @ 16:40

@a quelli che “mi sembra vista, ma gnome è meglio, io tanto uso e17″:

“This week we should be seeing lots of nifty new artwork going into kde4.0 And we have an adjourned meeting with plasma pannel people :)”

…e non vi dico chi l’ha scritto pochi minuti fa nel suo blog… tiè!

27. SharkP - 23/10/07 @ 16:43

Come si fa ad aggiornare di volta in volta?

28. .:FireFox:. - 23/10/07 @ 16:47

@ziabice:

dicevi questo: http://pinheiro-kde.blogspot.com/2007/10/move-lets-move.html ????

29. roccoo - 23/10/07 @ 16:55

il mio ci sta mettendo mooolto più di 2 ore… celeron m 1.5 ghz
comunque credo sia un problema di connessione… è da giorni che qualsiasi server che abbia un minimo a che fare con linux è preso d’assedio

30. roccoo - 23/10/07 @ 16:56

azz mi sono sbagliato 1 ora e mezza fin’ora, sto a kdepimlibs

31. frank95com - 23/10/07 @ 17:09

Consiglio per tutti. Non tentate di installare KDE4 da svn se avete gia un’installazione delle qt4 o dei moduli di kde nel vostro sistema, in quanto poi si creerebbero dei duplicati delle librerie e molto spesso il compilatore non riesce a sapere in quale directory sta la giusta libreria.
Fidatevi, MEGLIO DI NO!

32. frank95com - 23/10/07 @ 17:10

a ziabice: ihih, hai perfettamente ragione. Grande Nuno e tutto il team di KDE.

33. Luciana - 23/10/07 @ 17:25

ok ciao scusa ti ho scritto in contributi ma mi sa che ho sbagliato. cmq dicevo che ho trovato questo posto per caso e ho letto una cosa che mi interessa motlo. mi servirebbe una mano….
posso contattarti via email?

34. Andrey - 23/10/07 @ 17:52

@Vide
Grazie, appena arrivo a casa installo kde4base-dev e poi vediamo! :D

35. VOGLIO I DRIVER ATI 8.42 - 23/10/07 @ 17:52

VADO UN PO O.T. SCUSATEMI MA I DRIVER ATI QUANDO ESCONOOOOOOOOOO :-(

36. Jaba - 23/10/07 @ 17:56

(clap clap clap) devo ammettere che ormai non ho più scuse :D ” Questo DE s’ha da prova’ ”

Un grazie diretto a Felipe che s’è sbattuto - aggratisse!! - per ogni singolo utente che metterà in pratica questa sua guida - me per primo, o quasi. Da parte di tutti noi, grazie.

Felipe sarà solo Felipe - ma pollycoke :) rulla, non ci son cazzi che tengano

-Jaba

37. Neff - 23/10/07 @ 17:56

Grande! Tuttavia non ho fretta di usare KDE4, aspetterò Nnatale… dopotutto se si scartano i pacchetti prima del tempo che gusto c’è?

38. Iniezione di stile in KDE 4 « pollycoke :) - 23/10/07 @ 18:12

[...] è proprio il pannello, che al momento pare essere poco più che un segnaposto. Beh che aspettate? Correte ad installare o resterete indietro per sempre! [...]

39. lello - 23/10/07 @ 18:15

Ciao a tutti, seguo da tempo ma è il mio primo post.
Una domanda ed una osservazione:
è da tempo che compilo kde con kdesvn ma non ho mai dovuto apportare modifiche a sudo.
E poi la domanda ma cove ca… si compila nepomuk? Le ho provate tutte ma il nepomukdaemon non riesco a trovarlo da nessuna parte?

ciao e buon blog,
Lello.

40. dalloliogm - 23/10/07 @ 18:34

eh ma chi cavolo c’ha tempo :)

41. nea - 23/10/07 @ 18:34

Come posso risolvere il problema:
checking for aRts-1.1… /home/nea/src/kde4/kdelibs/configure: line 42396: cd: /home/nea/kde: No such file or directory
configure: error: aRts 1.1 not installed in the same prefix as KDE!
Please reinstall aRts in the same prefix as KDE, different prefixes are not
supported right now.

(kdelibs prefix is /home/nea/kde, aRts prefix is /usr)

grazie

42. Vide - 23/10/07 @ 19:01

nea: arts?!?!?! che diavolo stai compilando? kde 3.5? no perchè in KDE 4.0 arts non esiste nel modo più assoluto

43. SharkP - 23/10/07 @ 19:04

Ho un problema con kdenetwork, la compilazione si blocca ad un certo punto. Nel log le righe sono tutte un “deprecated”, per esempio:
“/usr/include/qt4/Qt3Support/q3boxlayout.h:60: warning: ‘__base_ctor ’ is deprecated (declared at /usr/include/qt4/QtGui/qboxlayout.h:69)”
Cosa sbaglio?

44. roccoo - 23/10/07 @ 19:24

ok ci ha messo 3 ore e mezza per installare, e ora tocca ai pacchetti….

45. Luca - 23/10/07 @ 19:39

Allora, KDE4 sono riuscito a installarlo (anche se non usando la guida di Felipe bensì un kdesvn-buildrc da me modificato). Tutto a posto e rullante TRANNE amarok2! Per quanto imprechi e copi il comando di felipe, non si vuole installare! Provando a installare etragear/multimedia e guardando all’errore nel log, mi dice che manca il target di make install…sono l’unico in questa situazione? :’(

Altra cosa: ma okular vedrà reimplementato il supporto ai pdf, vero? Perché l’ho provato sembra molto interessante…ma manca il supporto ai PDF al momento!

46. nea - 23/10/07 @ 19:52

@vide: hai ragione… ma me lo chiede come dipendenza per compilare!!!!
perchè???

47. nea - 23/10/07 @ 20:08

a proposito… kde4base-dev porta con sè diversi pacchetti tra cui kdelibs5 e kde4base… non è che si fa del casino con le nuove kdelibs da svn???

48. nea - 23/10/07 @ 20:33

Rimuovendo tutte le lib di aRts ottengo:

configure: error: The important program mcopidl was not found!
Please check whether you installed aRts correctly or use
–without-arts to compile without aRts support (this will remove functionality).

Non mi sembra abbia molto senso!!!

49. piivi - 23/10/07 @ 20:44

@nea non usare lo script che c’è su kubuntu, è quello per kde 3.5 usa il link di felipe
@luca io l’ho installato ieri senza problemi… forse è un problema temporaneo
@lello lottiamo insieme per questo azz di nepomuk.. non ci riesco nemmeno io!!! qualcuno ci aiutiiii

50. Asriel - 23/10/07 @ 20:46

ma è nromale che ci metta un bordello di tempo quando fa “finalizing subversion information for …”

ah, ha appenna fallito di scaricare kdelibpims. andrà lo stesso?

51. piivi - 23/10/07 @ 20:53

@asriel… sarà dura :)

52. Asriel - 23/10/07 @ 21:00

@pivi riferito a cosa, altempo che ci mette o a kdelibpims? XD

53. piivi - 23/10/07 @ 21:01

@asriel “ah, ha appenna fallito di scaricare kdelibpims. andrà lo stesso?”
piivi: “no”

54. nea - 23/10/07 @ 21:10

@ piivi: ora pare funzioni (ho cancellato tutti i file esistenti e rimesso tutto da capo!!!)… la cosa strana È CHE HO SEMPRE USATO lo script di Felipe!!!

…Forse avevo fatto un po’ di pocio con i vari file di config… sai la mia ubuntu di test è veramente un porcaio!!!! :-)

grazie!!!

55. furester - 23/10/07 @ 21:12

volevo segnalare che per Archlinux ci sono in AUR i PKGBUILD, quindi basta prendere quelli e compilarli con versionpkg .. o ancora meglio usare aurbuild\yaourt\… per fare tutto il procedimento in automatico (e incrociare le dita sperando che tutto fili liscio).

Nel caso di problemi si può vedere su http://developer.kde.org/~dirk/dashboard/ quali parti compilano e quali no.

56. piivi - 23/10/07 @ 21:17

@nea si tu hai usato i lfile di configurazione di felipe, non lo script indicato nel link! prob hai usato da shell quello di default di kubuntu!! cmq buon per te! fammi sapere magari se ti compila nepomuk! ;)

57. Fabio - 23/10/07 @ 21:33

felipe, questa tecnica mi sovrascive il mio kde3?

58. Asriel - 23/10/07 @ 21:35

avvea fallito a scaricare pure kdebase… ho tolto… ma che stiano aggiornando i file proprio ora?

59. piivi - 23/10/07 @ 21:39

i file sono aggiornati continuamente

60. Asriel - 23/10/07 @ 21:41

sì, io intendevo nel senso la cancellazione del file mentre stavo scaricando io…

61. frank95com - 23/10/07 @ 22:19

okular ha il supporto ai pdf, ma bisogna compilare poppler DA SORGENTE, mi raccomando. Poi devi ricompilare il modulo.

62. tosky - 23/10/07 @ 22:34

@Luca e frank95com
Non serve ricompilare poppler da sorgente, quello pacchettizzato è sufficiente (avendo la libreria di sviluppo ed una versione >=0.5.4).
Anche le qt4 possono essere quelle di sistema (almeno le 4.3.1).

63. Alfredo - 23/10/07 @ 22:43

Io ci ho provato ma continua a darmi questo errore… :(

Checking out kdenonbeta
svn: L’URL ’svn://anonsvn.kde.org/home/kde/trunk/kdenonbeta’ non esiste
Error updating kdenonbeta, removing from list of packages to build.

64. tosky - 23/10/07 @ 23:41

kdenonbeta non esiste più.

65. roccoo - 24/10/07 @ 0:07

con kde installato in questo modo non riesco a compilare amarok perché il mio sistema crede che non esiste kde, come faccio a disinstallare tutto??

66. dadokkio - 24/10/07 @ 0:17

è quasi tutto filato liscio…l’unica cosa che mi sta dando problemi è amarok..dal log credo di capire che manca qualche altra dipendenza,,evidentemente ruby1.8-dev non era l’unica necessaria… come faccio a sapere quali sono le altre?!?

67. Infinity89 - 24/10/07 @ 7:22

@66
vedi il log del configure…

68. lello - 24/10/07 @ 9:24

@piivi
il nepomukdaemon si trova in kdebase/runtime/nepomuk
Se si usa lo script questa subdirectory non viene nemmeno scaricata. Basta che controllo nella
tua directory kdebase/runtime/.
Se non ce l’hai allora con “svn update” la scarichi.
Il problema è che comunque non riesco a farla compilare. (cmake mette tutto il risultato
della compilazione nella directory build.)
La compilazione dipende da due parametri di cmake Soprano_FOUND e Nepomuk_FOUND…
soprano ce l’ho, e anche nepomuk…ma allora perché ca..non si compila?

69. Fire - 24/10/07 @ 10:43

Mi spaventa il tempo..io che ho un athlon 1000 finisco il prossimo mese di compilare :-) ma ci provo lo stesso…

70. Gio - 24/10/07 @ 10:46

Sono un novello che più novello non si può!!!
Ma se non lo provo così… quando mai mi ricapita!!!

Grazie e Felipe. Ho appena dato il via alle danze!!! Ciao

71. piivi - 24/10/07 @ 12:05

@lello sn perplesso… kdebase lo compila senza problemi, tuttavia nemmeno nei log si trovano riferimenti ad una compilazione di nepomuk…cmq a me la directory è stata scaricata automaticamente…

72. lello - 24/10/07 @ 13:47

@pivi
il problema è che la compilazione di nepomuk è proprio commentata!!
se apri il CMakeLists.txt in kdebase/runtime/ ti accordi che la riga che
contiene la compilazione di nepomuk è commentata (si trova dopo Soprano_FOUND).
Il punto è: perché?
Se usi kdesvn-build non si compilerà mai, bisogna farlo a mano, a meno che qualche amichetto non ci dica come fare…
Io smetto di provare.

73. Gio - 24/10/07 @ 14:13

E figurati se andava liscio!!!
Non mi compila kdebase…
Le ultime righe del file error.log recitano diverse righe simili a questa:

CMake Error: Cannot find source file “/home/giovanni/src/kde4/build/kdebase/apps/nsplugins/callbackadaptor.cpp” for target “testnsplugin”
Tried extensions .c .C .c++ .cc .cpp .cxx .m .M .mm .h .hh .h++ .hm .hpp .hxx .in .txx

ovviamente ciascuna riga riferita ad un file diverso (qui callbackadaptor.cpp).
Effettivamente guardando in questa directory questi file non esistono, ma sono troppo ignorante in tema di compilazione per potermi dare una risposta da solo! :)
Qualche suggerimento? Grazie comunque.

74. piivi - 24/10/07 @ 14:34

@lello perche’ smetti? e’ proprio questo il bello! appena sn a casa provo a decommentare e a lanciare la compilazione :) see u

75. Anonymous - 24/10/07 @ 14:41

Su opensuse 10.3 io mi sono arreso ormai.. Quando non riesce ad installare, quando cmake fallisce ( ovvero sempre ). Sono due settimane che provo e ancora non c’è modo.. Qualcuno di voi ha suse?

76. felipe - 24/10/07 @ 14:42

@tutti:
Sono molto contento che la guida sia stata apprezzata!

Per la faccenda di nepomuk, che non compila nemmeno a me, sappiate che:
1. ho chiesto a qualche sviluppatore e non mi ha saputo dare risposta
2. non è presente nemmeno nel KDE Four Live CD. che è tutto dire…

Detto questo: buona compilazione! :)

77. alexpalex - 24/10/07 @ 14:45

@felipe:
per compilare amarok serve anche libtag1-dev non so se lo hai scritto…

Saluti

78. piivi - 24/10/07 @ 15:25

@felipe grazie mille! Ora mi avventuro nella ricompilazione di kdebase cn la modifica al file Cmakelist…. appena fatto scrivo il risultato.. incorciamo le dita :)

79. Asriel - 24/10/07 @ 16:42

<<>>
Building kdebase (1/1)
Preparing build system for kdebase.
Removing files in build directory for kdebase
Old build system cleaned, starting new build system.
Running cmake…
Unable to configure kdebase with CMake!
Overall time for kdebase was 1 minute, and 55 seconds.

aiuto

80. Asriel - 24/10/07 @ 16:45

il file di log cmake da lo stesso problema di giò. ma con altri file

81. Asriel - 24/10/07 @ 16:49

come non detto è proprio lo stesso file di gio…

82. Borzo - 24/10/07 @ 16:55

Qualcuno sa dove prendere lo sfondo con il fiore di KDE4?

83. Gio - 24/10/07 @ 16:57

Probabilmente è un problema di dipendenze… ma ho controllato e ricontrollato ripetutamente e tutto sembra OK.
Mi dispiace molto, mi sarebbe piaciuto riuscire nella
mia prima esperienza di quasi-compilatore!!!! :):)
Ciao e grazie

84. Asriel - 24/10/07 @ 17:05

gio, guarda, se capita sia a me che a te, può essere un problema del repository… io aspetterei qualche ora e riproverei…

85. Thunder Teaser - 24/10/07 @ 17:13

felipe, ho tradotto la guida alla compilazione di KDE 4 in ITALIANO!!!

P.S.: Mi scocciavo di tradurre i template, magari lo farò un altro giorno! :P
P.P.S.: Se notate degli errori contattatemi oppure modificate voi stessi!

ENJOY! :)

86. lello - 24/10/07 @ 17:14

@pivi
non è che smetto è che ora devo lavorare…
@felipe
se mi permetti…ci vuole subito un post sui nuovi driver 8.42.3 della ATI…io li ho appena installati ma ho qualche problema con il DRI.

87. Gio - 24/10/07 @ 17:20

Scusate… faccio l’ultima richiesta e smetto, prometto :):)
(capisco che qui non siamo in un forum!!!)
Nel file error.log di kdebase trovo questi messaggi ‘not found’:

– Looking for Q_WS_WIN - not found.
– Looking for Q_WS_QWS - not found.
– Looking for Q_WS_MAC - not found.
– Looking for pthread_create in pthreads - not found
– Looking for include files HAVE_UTIL_H - not found.
– Looking for include files HAVE_LIBUTIL_H - not found.
– Looking for getpeereid - not found
– Looking for mallinfo - not found.
– Looking for getpassphrase - not found
– Looking for XF86MiscSetGrabKeysState in Xxf86misc - not found
– Looking for include files HAVE_DEVINFO_H - not found.
– Looking for include files HAVE_LINUX_RAW_H - not found.
– Looking for include files HAVE_ALIB_H - not found.
– Looking for include files HAVE_SYS_SOCKIO_H - not found.
– Looking for getnameinfo - not found.
– Looking for systeminfo - not found.
– Looking for getdomainname - not found.
– Looking for include files HAVE_CRT_EXTERNS_H - not found.
– Looking for _NSGetEnviron - not found
– Looking for setusercontext - not found
– Looking for login_getclass - not found
– Looking for auth_timeok - not found
– Looking for authenticate in s - not found
– Looking for sched_yield in posix4 - not found
– Looking for connect in socket - not found
– Looking for arc4random - not found
– Looking for setproctitle - not found

Sono tutti normali oppure qualcuno di questi ‘not found’ è importante?
Grazie e scusate ancora!!!

88. felipe - 24/10/07 @ 17:27

@Thunder Teaser:
Una parola sola: GRANDE! :)

89. lello - 24/10/07 @ 17:52

@tutti e col permesso di felipe
Oggi è una grande giornata…a parte il jeans mangiato dall’acido solforico
Ho un KDE4 appena compilato con effetti 3D direttamente con driver fglrx della ati 8.42.3
E’ davvero una figata…tutto integrato senza dover lanciare compiz o quant’altro.
Certo non è compiz, il 3D in KDE è ancora molto elementare, ma promette mooolto bene.
E la Ati ci ha finalmente fatto questo regalo di natale.
Il driver non è ancora perfetto, ma per divertirsi va benissimo.

Scusami il piccolo OT…

90. David Vignoni - 24/10/07 @ 19:11

Grazie per le istruzioni Felipe. Da quando mi sono trasferito non ho più lavorato su Oxygen. Ieri ho preso un portatile apposta per installarci KDE e lavorare sul tema, e le tue istruzioni chiarissime e soprattutto in italiano saranno un grandissimo aiuto per rimettermi in carreggiata al più presto. Good job, thanks!

91. roccoo - 24/10/07 @ 20:06

come faccio a cancellare tutto?? voglio reinstallarlo col metodo facile così funziona amarok

92. Borzo - 24/10/07 @ 20:52

anche io ho lo stesso problema di gio nella compilazione, qualche suggerimento?

93. Borzo - 24/10/07 @ 20:56

[email protected]:~$ sudo kdesvn-build –reconfigure kdebase
Script started processing at Wed Oct 24 20:55:49 2007
<<>>

Updating kdebase

<<>>

<<>>
Building kdebase (1/1)
Preparing build system for kdebase.
Removing files in build directory for kdebase
Old build system cleaned, starting new build system.
Running cmake…
Unable to configure kdebase with CMake!
Overall time for kdebase was 18 seconds.

<<>>

<<>>
kdebase - ~/src/kde4/log/2007-10-24-10/kdebase/cmake.log
Script finished processing at Wed Oct 24 20:56:11 2007
Your logs are saved in /home/borzo/src/kde4/log/2007-10-24-10

94. barabba - 24/10/07 @ 21:17

Idem lo stesso problema di Giò e Borzo :(

95. Borzo - 24/10/07 @ 22:13

Su google non ho trovato nulla, a sto punto aspetto che qualcuno che ne sappia ci dia una mano.

96. Anonymous - 24/10/07 @ 23:06

@Giò e altri: anch’io ho avuto lo stesso problema. L’ho rapidamente “risolto” (si fa per dire) con un workaround: ho commentato una riga nel file /home/miahome/src/kde4/kdebase/apps/CMakeLists.txt aggiungendole davanti un #. La riga è quella con scritto

add_subdirectory( nsplugins )

verso la fine del file. Naturalmente è solo un workaround temporaneo, però mi ha permesso di compilare con successo kdebase ;)

97. arunax - 24/10/07 @ 23:12

Ehm scusate il numero 96 ero io.

98. Borzo - 24/10/07 @ 23:57

grazie arunax, ora riprovo… ma quello che è commentato a cosa serve quindi?

99. felipe - 25/10/07 @ 13:15

@David Vignoni:
Grazie a te, sempre! E complimenti/auguri per le novità della tua vita :)

100. arunax - 25/10/07 @ 17:38

Serve a installare gli nsplugins, che - a quanto ho capito - sono plugins netscape (mozilla?) per konqueror. Può darsi che mi sbagli, comunque non penso sia nulla di importante, io vivo benissimo senza dato che or ora scrivo da KDE 4 ;)

Comunque ne approfitto per aggiungere che per compilare dopo il commento non penso sia il caso di dare semplicemente kdesvn-build, dato che riaggiorna tutti i sorgenti… non ho provato a farlo perchè sono partito direttamente dando il comando

kdesvn-build –build-only

101. Gio - 25/10/07 @ 17:45

@arunax

Grazie per il suggerimento. Avevo pensato a qualcosa del genere ma non trovato la giusta riga per commentare. Comunque alla prima prova di oggi ha compilato tutto correttamente (senza commentare alcunchè).
Però, data la mia fortuna in queste cose, nonostante la compilazione con successo KDE4 non parte!!! :) :)

Ma siccome only the braves vanno avanti mi armo di coraggio e riprovo fino a quando non mi si fonde il mio (già provato!!!) PIV 2 Ghz!!! Ciauz

102. Dareus - 25/10/07 @ 18:22

per i poveri mortali che non sanno come fare, non è che qualcuno potrebbe postare la procedura per avviare kde4 da kdm?
a sapere il contenuto del file /usr/lib/kde4/share/apps/kdm/sessions/kde.desktop installato con kdebase-workspace (kubuntu) ci si mette un attimo, altrimenti…
si soffre

103. Gio - 25/10/07 @ 18:36

Ce l’ho fatta!!!

@Dareus e gli altri:
Per avviare da KDM dopo aver fatto tutto quanto detto da Felipe basta eseguire i seguenti passi:
creare un file kde4.desktop ed infilarci dentro le seguenti righe:

[Desktop Entry]
Encoding=UTF-8
Type=XSession
Exec=kdesvn-start
TryExec=kdesvn-start
Name=KDE4 - Versione SVN
Comment=KDE4 - Versione SVN

e salvarlo nella directory /usr/share/xsessions
Tenendo presente che dovete sostituire a kdesvn-start l’eventuale nome dato al file suggerito da felipe. (io l’ho lasciato come diceva lui!)
Dopodichè scollegatevi e ricollegatevi utilizzando la nuova voce del menu di KDM!!!
Il tutto liberamente ispirato ad un mix tra il post di felipe e quello di Trevino. Grazie a tutti!!! Ciao

104. eman - 26/10/07 @ 11:06

Perchè non mettere nel pollyrepo un kde4 svn compilato da te?

105. aNoNiMo - 26/10/07 @ 11:14

argh! finalmente ho avuto il tempo di compilare il tutto.. cheddire.. PROVATE KOFFICE CHE E’ DA SBAVO!!! :P

106. Chetto - 26/10/07 @ 15:35

Siete tutti su 386 voi? Io ho un amd64…

107. Dareus - 26/10/07 @ 15:46

io sono su amd64 e non ho avuto problemi.
Un’altra domanda: e se io volessi usare /usr/kde4 come source-dir?
La home è già pienotta…

108. luca - 26/10/07 @ 16:08

appena provato il KDE Four Live cd basato sulla beta3 ed opensuse..
di idee brillanti ce ne sono e lasciano ben sperare per le future release, continuo a non capire (o forse non sono ben informato) perche’ hanno stravolto tutto quello che c’era in kde3, un taglio netto con il passato.
Avranno di che lavorare per renderlo stabile e performante.

109. montoya83 - 27/10/07 @ 12:03

consiglierei di aggiungere al file di configurazione queste 2 righe:

module l10n-kde4/it
end module

ps: alla data di oggi può dare errore perchè quando compila dice messaggi tipo “kspell non è stato definito”. Cercate nei sorgenti e cancellate le occorrenze &kspell… una volta tolte, compila perfettamente ;)

110. Ciso - 27/10/07 @ 17:37

Basta fare il –reconfigure per aggiornare i singoli “moduli”?

111. fred_84 - 27/10/07 @ 20:38

Con Ubuntu Gutsy, compilando KDEBASE ho questo errore:

/opt/kde4/lib/libnepomuk.so: undefined reference to `Soprano::DummyModel::DummyModel()’
collect2: ld returned 1 exit status
Linking CXX executable keditbookmarks
make[2]: *** [apps/dolphin/src/dolphin] Error 1

Qualcuno ha avuto lo stesso problema e può dirmi come raggirare il problema?
Ho già aggiornato gli altri pacchetti da svn seguendo la guida.. ma continua a darmi questo errore.

AIUTATEMI VI PREGOOOOOOOOOOOOOOOOOO!!!!!

112. jewelz - 27/10/07 @ 21:07

a me da errore addirittura con le kdelibs: ecco la riga di log che dovrebbe descrivere l’errore:

Scanning dependencies of target kconfig_compiler
Generating kdebugdbusiface_p.moc
kde4automoc: process for /home/andrea/src/kde4/build/kdelibs/kdecore/kdebugdbusiface_p.mocfailed to start: Unknown error

però sinceramente non è che dia informazioni proprio complete…. grazie a chi mi aiuterà

113. montoya83 - 27/10/07 @ 23:20

Se trovate errori strani di linking, consiglio di cancellare il CMakeCache.txt dentro la directory build del programma specificato. Se persiste, cancellate tutta la dir build del vostro programma.

114. Thunder Teaser - 28/10/07 @ 3:44

@ #102 Dareus: controlla qui!

115. Thunder Teaser - 28/10/07 @ 3:45

Non capisco che succede con i tag… comunque: http://techbase.kde.org/Getting_Started/Build/KDE4_%28it%29#Creare_un_account_utente_per_lo_sviluppo_di_KDE4

116. Ocin - 28/10/07 @ 18:12

<<>>
Building kdebase (1/1)
Preparing build system for kdebase.
Removing files in build directory for kdebase
Old build system cleaned, starting new build system.
Running cmake…
Unable to configure kdebase with CMake!
Overall time for kdebase was 17 seconds.

<<>>

<<>>
kdebase - ~/src/kde4/log/2007-10-28-02/kdebase/cmake.log

Dal cmake.log
…….
CMake Error: This project requires some variables to be set,
and cmake can not find them.
Please set the following variables:
OPENGL_gl_LIBRARY (ADVANCED)

Oltre agli scontati (ma dovuti) ringraziamenti a Felipe, qualcuno puo’ aiutarmi?

117. Aggiornata la guida alla compilazione di KDE4 « pollycoke :) - 29/10/07 @ 3:01

[...] Aggiornata la guida alla compilazione di KDE4 29 Ottobre 2007 @ 3:01 Posted by felipe in KDE, News e altre Sciccherie, Pollycoke. trackback Solo una piccola comunicazione: ho apportato numerose migliorie alla guida “KDE 4 per Ubuntu Gutsy, in un paio d’ore ;)“ [...]

118. Molly - 29/10/07 @ 4:00

Curioso effetto dell’ora legale è che si vedono post….dal futuro!

119. Tempo di Build… come velocizzarle. « gioitech - 29/10/07 @ 8:23

[...] di Build… come velocizzarle. Ottobre 29th, 2007 — gioi Leggendo l’articolo sulla compilazione da svn di Kde, su pollycoke, ho deciso di scrivere questa mini-guida per velocizzare le compilazioni.Diciamocelo [...]

120. lello - 29/10/07 @ 8:55

@fred_84
anche a me dà lo stesso errore da qualche giorno. Secondo me avranno fatto casino
con le librerie soprano. Ho provato in vari modi. Senza soprano kdelibs non si compila nemmeno quindi non è possibile disabilitarlo (almeno credo). Sto solo
aspettando che mettano a posta i sorgenti.
Oggi riprovo per l’ennesima volta…

121. felipe - 29/10/07 @ 9:59

@tutti:
Chi ha problemi di “undefined reference to `Soprano::DummyModel::DummyModel()’” mi fa pensare che non abbia seguito le mie istruzioni… in quanto il problema avviene mescolando kdesupport distribuito in pacchetti e quello compilato.

La soluzione è disinstallare il modulo kdesupport da voi compilato. Infatti nella guida (e nel mio file di configurazione di kdesvn-build) quel modulo è disattivato.

Altri errori sono quasi sempre dovuti alla mancanza di librerie necessarie alla compilazione, a temporanei stati del repository svn o da precedenti esperimenti con compilazioni di KDE4. In tutti questi casi consiglio di eliminare il tutto, pulire bene e ricominciare seguendo solo questa guida. :)

122. Anonymous - 29/10/07 @ 10:59

Grazie Felipe :D Stasera, mentre suono, ci riprovo :D

123. giul - 29/10/07 @ 12:23

Ciao Felipe, io ho kde 3.5.8 e Gutsy, da quello che ho capito seguendo la guida e configurando tutto per bene all’avvio si può scegliere se avviare kde3 o kde4???
Se si, da dove??

PS–>domani dovrebbe essere un giorno importante per kde4, se non sbaglio esce la RC1?

124. Thunder Teaser - 29/10/07 @ 12:29

Hohoh! Per me è un onore! ^^

125. cover - 29/10/07 @ 13:09

@giul:

domani release della beta 4, il tag della rc1 è il 14 novembre :)
http://techbase.kde.org/Schedules/KDE4/4.0_Release_Schedule

126. giul - 29/10/07 @ 14:12

raga ma mi confermate che all’avvio potro scegliere se avviare kde 3.5.8 o il 4…

aspetto solo questa risp per iniziare ad aggiornare… :(

127. Anonymous - 29/10/07 @ 14:58

Ragazzi a me non trova autoconf, eppure è installato.. :(

128. Dareus - 29/10/07 @ 15:32

@ 126 giul
sì, potrai scegliere da kdm/gdm che versione avviare

Grazie per i consigli, comunque a me da problemi con il modulo italiano, non ho capito cosa commentare/decommentare

129. me - 29/10/07 @ 18:43

scusate, ma voi riuscite a far andare amarok??
Io ho selezionato come motore xine, ma nè con questo, nè con phonon mi riproduce niente…

130. olympicmew - 29/10/07 @ 19:34

anch’io ho problemi con la localizzazione italiana, cosa devo fare?

131. Savvatore - 29/10/07 @ 20:26

da utilizzatore felice di gnome e generalmente esiguo utilizzatore di KDE
per la sua troppa voglia di avere mille software che fanno la stessa cosa
credo che aspetterò o l’ uscita ufficiale o meglio kubuntu con kde4 tanto tra sei mesi esce la 8.04
e di kde 4 ancora non se ne vede l’ ombra.
cmq ottima guida sopratutto utile l’ aggiornamento per inserire la sessione in gdm

132. myway - 29/10/07 @ 21:45

felipe, forse c’è un errore nelle indicazioni del file kde4.desktop:
in /opt/kde4/bin/ c’è startkde.. non startkde4, almeno da me..

133. felipe - 29/10/07 @ 21:51

@myway:
Grazie! Corretto :)

134. roccoo - 29/10/07 @ 22:31

mancano sempre le istruzioni per cancellare tutto :(

135. Gio - 29/10/07 @ 22:34

Salve a tutti.
Preciso che ho iniziato la mia avventura compilativa con la prima versione di questo post e che continuo con le directory in home.
Volevo solo chiedere a Felipe due cosacce, a ‘mò di chiarimento:
1) c’è un motivo particolare per cui hai modificato la guida per l’installazione in /opt? (ergo c’è un motivo per cui dovrei ripartire da zero con la compilazione in /opt oppure posso continuare a godermi il tutto alla “vecchia maniera”??? :):)
2) l’eliminazione della modifica a sudoers che indicavi nella prima versione della guida vale anche per chi, come me, continua a buildare in HOME?

Grazie comunque per tutto. Ciao

136. Andrea - 29/10/07 @ 22:48

mi da un errore nella compilazione di l10n:

[ 91%] (28607)/ KLocalizedStringPrivate::toString: “Trying to convert empty KLocalizedString to QString.”
meinproc4(28607) main: couldn’t find xmllint
Generating index.cache.bz2
(28614)/ KLocalizedStringPrivate::toString: “Trying to convert empty KLocalizedString to QString.”
meinproc4(28614) main: couldn’t find xmllint
/usr/src/kde4/build/l10n-kde4/it/docs/kdepim/kmail/using-kmail.docbook:537: parser error : Entity ‘kspell’ not defined
>&kspell; ^
/usr/src/kde4/build/l10n-kde4/it/docs/kdepim/kmail/using-kmail.docbook:2925: parser error : chunk is not well balanced

^
/usr/src/kde4/build/l10n-kde4/it/docs/kdepim/kmail/index.docbook:198: parser error : Failure to process entity kmail-using-kmail
&kmail-using-kmail;
^
/usr/src/kde4/build/l10n-kde4/it/docs/kdepim/kmail/index.docbook:198: parser error : Entity ‘kmail-using-kmail’ not defined
&kmail-using-kmail;
^
Segmentation fault (core dumped)
make[2]: *** [docs/kdepim/kmail/index.cache.bz2] Error 139
make[1]: *** [docs/kdepim/kmail/CMakeFiles/handbook.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs….
[ 91%] Built target handbook
make: *** [all] Error 2

137. felipe - 29/10/07 @ 22:50

@roccoo:
sudo rm -rf /opt/kde4 /usr/src/kde4

@Gio:
1. serve ad avere kde4 disponibile per più utenti, se lo usi solo tu lascialo in $HOME e continua come prima
2. la modifica a sudoers ti serve sempre

138. Gio - 29/10/07 @ 22:54

Grazie per le risposte flash.
Ti vuogghiu ‘cca saluti!!! Byte-

139. flavio - 29/10/07 @ 23:38

questo è l’errore che ottengo compilando kdebase.
ho installato le dipendenze (libstdc++5-dev e anche 6-dev)

checking if C++ programs can be compiled… no
configure: error: Your Installation isn’t able to compile simple C++ programs.
Check config.log for details - if you’re using a Linux distribution you might miss
a package named similar to libstdc++-dev.

140. mark - 29/10/07 @ 23:42

Building extragear/multimedia (1/1)
Preparing build system for extragear/multimedia.
Running cmake…
Unable to configure extragear/multimedia with CMake!
Overall time for extragear/multimedia was 7 seconds.

LOG —>
– Found KDE 4.0 include dir: /opt/kde4/include
– Found KDE 4 library dir: /opt/kde4/lib
– Found KDE4 kconfig_compiler preprocessor: /opt/kde4/bin/kconfig_compiler
– Found KDE4 automoc: /opt/kde4/bin/kde4automoc
CMake Error: Could not find REQUIRED package Taglib
– Configuring done

141. giul - 30/10/07 @ 0:58

che è successo??
mi date una mano??

Script started processing at Tue Oct 30 00:51:45 2007
<<>>

Checking out kdenonbeta
svn: L’URL ’svn://anonsvn.kde.org/home/kde/trunk/kdenonbeta’ non esiste
Error updating kdenonbeta, removing from list of packages to build.
Updating kdelibs

Updating kdepimlibs

Updating kdebase

<<>>

<<>>
Building kdelibs (1/3)
Preparing build system for kdelibs.
Executing rm -rf /usr/src/kde4/build/kdelibs
Old build system cleaned, starting new build system.
Running configure…
Unable to configure kdelibs! Nessun file o directory
Overall time for kdelibs was 3 minutes, and 29 seconds.

Building kdepimlibs (2/3)
Preparing build system for kdepimlibs.
Executing rm -rf /usr/src/kde4/build/kdepimlibs
Old build system cleaned, starting new build system.
Unable to create build system for kdepimlibs Nessun file o directory
Unable to create configure system from checkout. Nessun file o directory
Overall time for kdepimlibs was 0 seconds.

Building kdebase (3/3)
* Unable to find the make executable! Nessun file o directory

Unable to build kdebase!
Took 0 seconds.
Overall time for kdebase was 0 seconds.

<<>>

<<>>
kdelibs - /usr/src/kde4/log/2007-10-30-06/kdelibs/configure.log
kdepimlibs - /usr/src/kde4/log/2007-10-30-06/kdepimlibs/build-system.log
kdebase - No log file

<<>>
kdenonbeta - /usr/src/kde4/log/2007-10-30-06/kdenonbeta/svn-co.log
Script finished processing at Tue Oct 30 00:55:41 2007
Your logs are saved in /usr/src/kde4/log/2007-10-30-06
[email protected]:~$

142. flavio - 30/10/07 @ 9:26