jump to navigation

Sono un Ubuntero + News per il ppa pollycoke :)

In News, Pollycoke Repository il 18/02/09 @ 14:58 trackback

Avete problemi a compilare KDE 4.3svn e nonostante variopinte invocazioni rivolte al cielo non riuscite ad installare kdepimlibs (necessario per kdebase) e kdemultimedia?

Consolatevi: anche io. La soluzione sta in due librerie non sufficientemente aggiornate di Ubuntu Intrepid: libpulseaudio (richiesto da kdemultimedia) e libical (richiesto da kdepimplis). Ho provveduto a metterne versioni aggiornate semiufficiali - derivanti da jaunty - nel ppa pollycoke :). Ma ricordate cosa ho sempre detto: diffidare di repository esterni contenenti librerie. Quindi se non sapete esattamente cosa state facendo lasciate stare KDE 4.3 e lasciate stare il mio PPA. «Avvisaaati siete».

Ah, per poter caricare pacchetti su Launchpad ho fatto una serie di procedure e… insomma da oggi sono un Ubuntero. Chissà che implicazioni potrà avere una cosa del genere sul mio ego frammentato. Brrr… :D

Condividi questo articolo:

  • TwitThis 
  • FriendFeed 
  • Facebook 
  • Badzu 
  • LinkedIn 
  • Google 
  • del.icio.us 
  • Wikio IT 
  • DiggIta 
  • Technotizie 
  • OKNotizie 

Pagine forse correlate:

Etichette: ,

Commenti »

1. fasix - 18/02/09 @ 15:09

grande felipe
ma sul tuo repository per ora nn c’e’ Kde 4.3, giusto?
ed in un futuro prossimo?

2. HalphaZ - 18/02/09 @ 15:18

mi accodo alla domanda 1

3. sach - 18/02/09 @ 15:24

E sono l’unico ad avere problemi con kdeplasma-addons?

4. pinotree - 18/02/09 @ 15:30

Da notare che pulseaudio non è obbligatorio per kdemultimedia, ma solo opzionale.

5. Irruenza - 18/02/09 @ 15:44

grazie per ical e pulse……

6. felipe - 18/02/09 @ 16:15

@fasix:
@HalphaZ:
KDE 4.3 cambia troppo ma troppo in fretta per fare una cosa del genere ed esserne contenti. Per quello però c’è KDE Nightly!

@sach:
No, anche lì ci sono rivoluzioni ma che io sappia non legate a dipendenze mancanti

@pinotree:
Buffo perché ho cercato il modo di disabilitarlo. Ma se è opzionale come mai la compilazione moriva?

@Irruenza:
De nada :)

7. alek - 18/02/09 @ 17:26

ma solo a me compilando kde4.3 con qt4.5 sono comparsi degli errori grafici (per esempio nel toolbox in alto a destra) e quando clicco su termina sessione / spegni il computer ecc. mi si freeza kde4?

8. felipe - 18/02/09 @ 17:33

@alek:
1. È normale, da quanto avevo letto io mi aspettavo molto ma molto peggio, stanno sistemando imperfezioni come quella.
2. Non si blocca, è solo “nascosto”: premi Invio e vedrai che farà il logout regolarmente ;) In ogni caso da ieri è stato sistemato, aggiorna il tuo KDE!

9. Enrico - 18/02/09 @ 18:01

Anche io sono su Launchpad ;)
Sto utilizzando Jaunty di conseguenza segnalo qualche bug che trovo,magari domani mentre studio posso mettere a compilare KDE 4.3 . ;)

10. pinotree - 18/02/09 @ 18:09

@felipe:
beh, dipende in che modo moriva la compilazione ;)
In generale, dovrebbe servire passare -DWITH_PulseAudio=OFF a cmake per disabilitare la ricerca e l’uso di pulseaudio in kdemultimedia.
(In generale, sai come contattarmi per problemi del genere ;) )

11. alek - 18/02/09 @ 18:23

@felipe
grazie, era fastidioso non poter chiudere la sessione :) comunque io ho aggiornato anche oggi, ma continua a farlo. non appena escono le qt4.5 stabili mi sa che ricompilo tutto da zero

12. dalloliogm - 18/02/09 @ 19:13

eheh, anche io sono un Ubuntero!!
Benvenuto collega!

13. Radio - 18/02/09 @ 22:55

Libical? la 0.43? Quella che ieri ho compilato perché “no, è troppo recente, figurati se la trovo per intrepid”…xD

14. lolloso - 19/02/09 @ 6:55

pulseaudio ? aarrrgh via dalle p… ruote quel coso inutile.
vedo che però pinotree al #10 mi ha anticipato ;)
ecco comunque che una distro che aggiorna ogni 6 mesi (come tutte le cose) ha anche i suoi svantaggi: uno di questi sono proprio le libs che risultano presto vetuste.

cosa è chi è perchè Ubuntero ? :D

15. felipe - 19/02/09 @ 17:55

@pinotree:
Yes, so dove contattarti per romperti le scatole :D
Stavo giocherellando con ccmake ma a quanto pare deve essermi sfuggito lo switch per disabilitare, ad ogni modo il comportamento standard per dipendenze opzionali è un warning di cmake, qui non so perché ma si bloccava make.

@Radio:
:D

@Ubuntero:
Era solo per dare un titolo più felipesco all’articolo, in realtà autonominarsi pomposamente “Ubuntero” non cambia una virgola di niente. Di sicuro non cambierà la mia posizione di “cane sciolto” ;)

(commentando accetti implicitamente le Regole di pollycoke, leggile!)