jump to navigation

Pollyrepo news

felipe in: Articoli, Guide e HowTo, News e altre Sciccherie, Pollycoke Repository il 8/06/07 @ 16:48 , trackback
0 votes, average: 0 out of 50 votes, average: 0 out of 50 votes, average: 0 out of 50 votes, average: 0 out of 50 votes, average: 0 out of 5 (media: 0, registrati per votare)
Loading ... Loading ...

Sto compilando a manetta (quasi) tutto quello che vi avevo anticipato ieri, in pratica mezzo GNOME 2.19.[3,4]

I pacchetti aggiornati sono per ora Totem, Eye of GNOME, GTK2-Engines, GNOME Themes, Liferea, File Roller, Rhythmbox… Insomma veramente mezzo GNOME unstable.

Oltre a questo sto impacchettando altra roba e soprattutto sto cominciando a fornire anche i sorgenti dei pacchetti modificati, in modo da facilitare chiunque volesse provare a ricompilare per una architettura differente, tipo amd64 :) Consultate la pagina del repository per sapere come aggiungere anche il repo dei sorgenti.

Tutta questa attività di impacchettamento mi fa però venire qualche scrupolo… finora nessuno (da parte di GNOME e Ubuntu) ha obiettato niente sull’idea di impacchettare questi backports, e anzi l’idea è piaciuta e forse a breve potrete leggere un annuncio ufficiale di Ubuntu Italia ;) ma ci tengo ad essere chiaro e ricordo a tutti che il mio repository contiene software instabile e per niente supportato.

…e ciò è divertente :D

Commenti»

1. Ecas - 8/06/07 @ 16:57

Azz…dovrò creare una partizione apposita per la mia Ubuntu felipizzata..

:)

2. motumboe - 8/06/07 @ 16:57

bene, bravo, buon lavoro :-)

3. davide - 8/06/07 @ 16:58

ma usando i tuoi repo, o cmq ricompilandosi i pacchetti da gutsy (o come diavolo) non si va contro all’idea delle release regolari? non é meglio allora tornare a debian unstable? da cui in effetti i pacchetti di gutsy dovrebbero essere pescati?

4. elcamilo - 8/06/07 @ 17:01

beh, io mi fido.

p.s.: per l’aggiornamento di liferea vorrebbe rimuovere liferea-mozilla, no good!

5. davide - 8/06/07 @ 17:04

elcamilo, sono mesi che oramai liferea dipende da liferea-xul, liferea-mozilla non esiste piu

6. Ecas - 8/06/07 @ 17:14

Mi sono fidato. Sto provando EoG 2.19.3 … :D

PS : Uno sfondo bello da usare con il nuovo Gummy di Cimi ?

7. Filippo - 8/06/07 @ 17:26

Ciao,
scusa ma perchè dici che vuoi “fornire anche i sorgenti dei pacchetti modificati”?
I sorgenti non sono quelli che tutti possiamo scaricare con “apt-get source”?

O tu modifichi qualcosa?

8. UBox - 8/06/07 @ 17:32

Grazie infinite per tutto il tuo lavoro!!!
Grazie davvero!

9. lillipuziano - 8/06/07 @ 17:40

Ehm… speriamo bene! Nel caso, io uso KDE, non ci perdo nulla a togliere di mezzo lo gnomo instabile e reinstallare quello di feisty. :-)

10. UBox - 8/06/07 @ 17:55

ops, c’è un problema..
Liferea non me lo fa installare…
ho i pacchetti di getdeb installati, come mai?boh!

11. giovix - 8/06/07 @ 17:57

mmmmhhhhhhhh………….allora, poichè non voglio avere problemi di stabilità, mi sa che tolgo il tuo repo, mi spiace ma solo software affidabile e testato sulla mia ubuntu-box………..è che ormai sono diventato uno Slackwerista………….e la filosofia del grande Pat mi ha convinto ;) :))

Ciao e buon Ubuntu Stable a tutti!!!

12. giovanni recchia - 8/06/07 @ 17:59

Bravo: stai per diventare veramente famoso in pratica!

13. LuNa - 8/06/07 @ 18:09

@Felipe: anche a me piace sta cosa … questo e divertente :D man mano ti segnalo qui quello che mi sta funzionando e quello che no .. tanto ormai mi faccio tutte le tribe e gli aggiornamenti unstable possibili immaginabili … gioco nuovo fino a ottobre :)

14. Anonymous - 8/06/07 @ 18:10

felipe ma compili tutto te?????? sei un pazzo! grazie! appena riesco a sistemare definitivamente il computer aggiorno la feisty alla polly-feisty! grazie!Ciao!!!

15. elcamilo - 8/06/07 @ 18:27

@davide

grazie: adesso lo sostituisco. Per quanto, beh, io uso Linux da 2 mesi circa, scusa tanto anche per questo! (ma vai a cag…!!:-)

16. Vigliag - 8/06/07 @ 18:32

Grazie per i pacchetti !
Sei un grande! Continua così!!!

17. Luigi - 8/06/07 @ 18:38

Grazie per i pacchetti, fortunatamente non sembrano troppo instabili. (comunque se lo fossero mi basterebbe reistallare la versione di feisty).

18. marcogoni - 8/06/07 @ 18:44

boh, secondo me non è molto utile questa mega compilazione di cose ultrainstabili.
già feisty in se non scherza se ci aggiungiamo anche gnome 2.19 compilato da te, chissà dove si arriva!
le versioni instabili servono solo agli sviluppatori, e sanno benissimo come compilarsi da se i pacchetti!
o c’è un motivo che mi sfugge?

19. marcogoni - 8/06/07 @ 18:51

aggiungo una cosa: dopo due anni di Ubuntu&Gnome sono tornato a Debian testing & Fluxbox + Thunar quando serve. non avere icone sul desktop è spettacolare. non è una questione di ascetismo… è solo che la mia produttività è triplicata, la cpu lavora solo quando effettivamente lancio un programma che mi serve, gli 1.5Gb di Ram sono quasi tutti a disposizione etc etc… l’unico sfizio è gkrellm :-D

sometimes less is (much) more

20. mambro - 8/06/07 @ 19:14

Secondo me a breve passerai a gentoo :-)

21. frog - 8/06/07 @ 19:38

se polly non va alla gentoo … la gentoo verrà dalla ubuntu felipizzata.
non nascondo che la gentoo sia una ficata, ma non è per tutti, al contrario di ubuntu, e stabilità significa anche sicurezza.

22. Anonymous - 8/06/07 @ 19:40

Ma se devi usare tutta roba instabile non è meglio se passi direttamente a gutsy?

23. 2dvisio - 8/06/07 @ 19:49

In pratica stai creando un ramo unstable tutto per Ubuntu… :D

24. faithful - 8/06/07 @ 20:23

Compilerai i GTK-engines alla Pollycoke o seguirai le direttive dello gnome- artwork-team?

25. Filippo - 8/06/07 @ 20:36

Leggete il commento di Cimi, sul suo blog http://cimi.netsons.org/blog/2007/06/08/gtk-engines-e-ubuntu-non-usate-i-deb-di-pollycoke/,
riguardo i pacchetti gtk-engines che si trovano sul repo di felipe.

Ciao ciao.

26. Giordy72 - 8/06/07 @ 20:49

Felipe secondo me Cimi non ha tutti i torti, dovresti firmare i pacchetti quando li modifichi. Non prendertela a male eh!

27. ulisse - 8/06/07 @ 21:44

Appoggio anch’io la critica di Cimi, se un pacchetto è modificato deve essere chiaramente distinguibile dall’originale.
Se le modifiche riguardano soltanto la compilazione, magari può anche andar bene così, dopo tutto è un repo di backports assolutamente non ufficiali, ma se le modifiche sono dettate dal gusto tuo personale la firma è d’obbligo!

28. ZioMatteo - 9/06/07 @ 0:28

Mio primo post! Un grazie a Felipe per il lavoro. Le critiche, se costruttive, ci stanno. Ma comunque grazie ancora.

29. freedreamer - 9/06/07 @ 0:32

felipe tracker non lo impacchetti? :)

30. Hoghemaru - 9/06/07 @ 1:49

ho appena installato gli aggiornamenti e dopo il riavvio (richiesto) compiz è diventato inutilizzabile (non carica il decoratore delle finestre e tutti gli altri plugin)

ora vedo se riesco a risolvere qualcosa tramite synaptic…

31. DierRe - 9/06/07 @ 1:55

In effetti ha ragione Cimi.

32. Top Posts « WordPress.com - 9/06/07 @ 1:58

[...] Pollyrepo news Sto compilando a manetta (quasi) tutto quello che vi avevo anticipato ieri, in pratica mezzo GNOME 2.19.[3,4] [image] I […] [...]

33. kwisatz - 9/06/07 @ 9:48

Secondo me non è associabile utilizzare questa repository ad usare gutsy o unstable, in fondo qui si aggiornano solo le applicazioni: se una dà problemi rimetto la versione precedente senza dover portarmi appresso decine di libAAA e libBBB. Comunque è un’indecenza che file-roller ancora non supporti il drag & drop! Ma siamo pazzi?!?!?!?

34. LuNa - 9/06/07 @ 10:00

kwisatz: VERO !! conosci qualcosa che invece lo fa (naturalmente in GTK) ?

35. LuNa - 9/06/07 @ 10:04

ecco perke sto gummy non somigliava a gummy -.-

36. EffE - 9/06/07 @ 10:40

In effetti preferisco il Gummy originale, non avrei voluto aggiornare ma non ci ho proprio pensato…
Come faccio a tornare alla versione gtk-engines di Cimi?

37. [email protected] - 9/06/07 @ 10:51

@EffE: Santa pazienza, nonchè terminale: questo serve per tornare alla precedente versione :)

38. Luca - 9/06/07 @ 11:06

Un infinito grazie per cose che molto probabilmente da solo non sarei stato
in grado di provare ed un infinito grazie per il tempo che hai impiegato per impacchettare il tutto.

Poi se sono stati cambiati alcuni dettagli non è un gran problema per me, se felipe ha fatto questi pacchetti così è perchè magari lui li usa con queste modifiche è non vedo perchè debba distribuirne altri; se ti piace la sua “politica” li scarichi e li usi… altrimenti ciccia ti rimbocchi le maniche..

39. Hoghemaru - 9/06/07 @ 11:08

ho rimesso il compiz 0.3.6 ma il problema rimane… qualcuno mi può aiutare?

sono in astinenza da finestre gommose…

40. Panarero - 9/06/07 @ 11:36

ragazzi perchè date la colpa a Felipe delle cose che non vanno.Mica è zio Bill che vi costringe a tenerli i repo e ad aggiornare tutto quello che compila.Linux è bello per la libertà di scelta quindi fatelo.

41. DierRe - 9/06/07 @ 12:24

Guardate che nessuno sta dicendo che non va bene che ci sia il repository. Cimi ha solo fatto presente che è necessario firmare i proprio pacchetti in quanto diversi dal gtk-engine originale.

42. Cisco - 9/06/07 @ 12:34

esatto, cimi infatti ha aggiunto una precisazione…

43. Xander - 9/06/07 @ 13:01

@ LuNa: sì, certe applicazioni in GTK supportano il DnD, anche abbastanza decentemente.

Un esempio su tutti? GIMP.

44. ILLuSioN²² - 9/06/07 @ 14:41

@Xander

anche brasero ma ce ne sono tanti…

45. giovix - 9/06/07 @ 16:27

Ognuno è libero di fare è installare ciò che vuole sul suo pc ,però poi, il giorno che comincerete ad avere problemi, perchè usando software unstable questo è possibile………..siete tutti pregati di non venirvi a lamentare qui con lacrime di coccodrillo :))

Ciao e buon Uby a tutti!!! :))

46. LuNa - 9/06/07 @ 19:42

@Xander: mi sono espresso male … forse … io desidero un archiver con questa funzionalita’. ;)

47. domi84 - 10/06/07 @ 11:39

A me l’aggiornamento di lifrea da errore, dice che non può installare “ubuntu-desktop” …. boh!!!

48. Giuliastro - 11/06/07 @ 11:14

Non e’ che impacchetti anche la versione 1.3.0 dell’xserver-org-core? Sembra si risolvano un po’ di problemi con Compiz / Beryl..

49. ramielinux - 11/06/07 @ 19:20

Certamente

50. Fabrizio "Ramiel" Ruggeri - 12/06/07 @ 17:33

Da’ lo stesso errore anche a me

51. Koalapazzo - 29/08/07 @ 16:12

Volevo solo avvisare che EoG ha un fastidiosissimo bug che fa chiudere il programma dopo una rotazione ed un salvataggio di un’immagine.
Inoltre il salvataggio con la versione del repo è veramente molto più lungo rispetto alla versione inclusa con feisty.

(commentando accetti implicitamente le Regole di pollycoke, leggile!)