jump to navigation

Pollycoke è anche un repository di pacchetti per chi vuole mantenere la propria Ubuntu ultra-aggiornata.

I pacchetti sono provenienti dalla versione di sviluppo di Ubuntu e ricompilati per la versione stabile con l’intento di condividere il frutto di ciò che ho esposto nella mia guida “Miscelare repository per compilare pacchetti più recenti“.

La motivazione principale che sta dietro al “pollyrepo” è quella di poter garantire agli utenti Ubuntu più avventurosi, pacchetti in versione di sviluppo e in anteprima rispetto al rilascio ufficiale.

Questo significa software aggiornatissimo e pieno di novità non ancora disponibili per tutti, ma spesso vuol dire anche software instabile. A voi la scelta :)

Ecco le righe da aggiungere al proprio /etc/apt/sources.list. La prima serve per i pacchetti binari, ed è l’unica necessaria, la seconda serve a quei pochi che volessero ricompilare i pacchetti:

deb http://download.tuxfamily.org/pollyrepo hardy/
deb-src http://download.tuxfamily.org/pollyrepo hardy/

Non ho impostato una chiave di autenticazione, quindi ogni volta che installate qualche aggiornamento dal pollyrepo verrà visualizzato un avvertimento che questi pacchetti non sono autenticati :)

Se qualcuno volesse sostenere il mio lavoro può usare il pulsante qui sopra per fare una donazione.

La politica del repository

Questo si può definire un “repository di backports con garanzie“, nel senso che:

Liberatoria

Pur con tutte le garanzie possibili, ricordate che questo software viene direttamente dalla versione instabile di Ubuntu.

Questo significa che potrebbe essere codice pieno di bug e difetti imprevedibili, che potrebbe portarvi a perdere dati, o a rovinare la configurazione del vostro PC, un po’ come se stesse usando la versione instabile di Ubuntu, per capirci. Ovviamente prima di mettere tutto online controllo sempre personalmente, ma questo non basta ad assicurare il funzionamento dei pacchetti al 100% e a tutti.

Per questo motivo non mi assumo nessuna responsabilità e vi invito a considerare attentamente prima di installare software da questo repository.

Guide per creare pacchetti

Per creare pacchetti per Debian, Ubuntu e derivate non ci vuole chissà quale scienza, basta seguire le guide catalogate sotto l’etichetta “Compilare“, in particolare “Compilare con Ubuntu: 4) Creare pacchetti Debian con dh_make“.

Altro discorso invece se avete in mente di diventare maintainer più o meno ufficiali per Debian o Ubuntu. In tal caso vi consiglio di sfruttare i canali “istituzionali” e soprattutto di spulciarvi la corposa documentazione.

Buon divertimento!

Commenti »

1. Brasero 0.7.1 per Ubuntu Gutsy [pollyrepo] | pollycoke :) - 31/01/08 @ 8:37

[...] Repository [...]

2. giomini - 31/01/08 @ 13:00

ma trevino non ha più fatto repository per gutsy?

3. neubauten84 - 31/01/08 @ 17:22

Pacchetti 64 bit, no??Ti prego…… :)

4. Metacity 2.21.5 con compositor per Ubuntu Gutsy [pollyrepo] | pollycoke :) - 31/01/08 @ 17:44

[...] Repository [...]

5. Compiz 0.6.99+GIT per Ubuntu Gutsy [pollyrepo] | pollycoke :) - 1/02/08 @ 0:31

[...] Repository [...]

6. robiw72 - 2/02/08 @ 20:15

i tuoi repo hanno cercato di rimuovermi compiz???

7. freedreamer - 3/02/08 @ 14:21

faccio una richiesta:
sarebbe possibile mettere nel repo mail notification 5?

grazie

PS
cancella pure il msg in messageBox

8. Ciso - 3/02/08 @ 21:55

@giomini:
trevino mi ha detto di persona che non demorde e spera di farli in un tempo utile :)

9. aMSN 0.97RC1 provato e impacchettato per Ubuntu Feisty [pollyrepo] « pollycoke :) - 4/02/08 @ 16:28

[...] Repository [...]

10. Giaku - 5/02/08 @ 13:30

ciao felipe!
Volevo fare una richiesta se era possibile..riusciresti a mettere gli ultimi ALSA nel repository?..ciao grazie mille!!

11. Metacity 2.21.8 con compositor per Ubuntu Gutsy [pollyrepo] « pollycoke :) - 5/02/08 @ 16:15

[...] Repository [...]

12. Giacomino - 5/02/08 @ 18:09

Ciao Felipe, vorrei chiederti se Amarok 2 è presente?
Poi che programma usi per creare pagine web del tuo sito, voglio sganciarmi da dreamweaver….ciao bello

13. FabioA - 5/02/08 @ 19:19

Ciao !

La mia speranza è di vedere un recentISSIMO amule… con tanto di EXE per windows per la gui remota… ho un fratello che stressa :p

14. masand - 5/02/08 @ 20:02

Felipe,
mi piacerebbe avere la compiz-tray-icon…

Un saluto a tutti…
masand

15. flyingecko - 6/02/08 @ 0:08

Perchè non inserisci i programmi alternativi a quelli mono?
Sarei curioso di provarli, specialmente Daze (il tomboy-clone), ma non li trovo neanche nei repo di Debian Sid.
Se li impacchetti potresti verificarne la perfetta compatibilità con mamma Debian?
Grazie in anticipo.
ciao

16. b3knight - 6/02/08 @ 0:14

Prima di tutto complimenti e grazie per lo "sporco lavoro che qualcuno deve pur fare"…

Poi vorrei chiedere, se possibile, un Deluge sempre aggiornato! :-)

17. Ciccio Pasticcio - 6/02/08 @ 1:24

chiedo troppo, Xlink kai funzionante su gutsy.

18. Al_Diseel - 6/02/08 @ 21:19

Felipe, se ti annoi potresti fare il backport di KOffice2, non l’ho mai visto :)

19. bluetrain - 7/02/08 @ 1:01

koffice 2 è ancora in alpha…credo sia un pò prematuro…

da parte mia invece…

caro babbonatale
quest’anno nel repository instabile per psicolabili e maniacodepressivi mi farebbe molto piacere trovare l’ultimissima versione di
ardour
rosegarden
tcl tk 1.5

se possibile poi vorrei anche una birra ghiacciata…
chi non sogna un bell’apt-get install really-fresh-beer??
ovviamente poi eseguendo il comando segreto r-f-b dal nostro lettore dvd uscirà una bionda gelida e dissetante…
ok..sclero a parte notte a tutti!

20. *Gian* - 7/02/08 @ 12:19

se riuscissi a impacchettarmi il nuvo glipper te ne sareio grato!

21. felipe - 11/02/08 @ 20:34

@giomini: È impegnato con l’uni, ma mi ha “promesso” che ha qualcosa in serbo per tutti noi :)

@neubauten84: Mi spiace, ma non supporto quell’arch :/

@robiw72: Aggiorna sempre da synaptic, alcune dipendenze di hardy non possono essere risolte altrimenti.

@freedreamer: Non è ancora in Hardy, ma terrò d’occhio eventuali novità ;)

@Giaku: Come spiegato in questa pagina, come garanzia di sicurezza non impacchetto librerie o moduli per il kernel, sorry :)

@Giacomino: Amarok2 è già presente nei repo di Kubuntu (cfr “KDE 4 per Ubuntu Gutsy, in dieci minuti ;)“)

@FabioA: Amule di Hardy al momento non è all’ultimissima versione, ma terrò d’occhio anche quello!

@masand: Che io sappia non è in Hardy

@flyingecko: Daze pare un po’ defunto purtroppo! La compatibilità con Debian è una cosa compicatuccia… specie perché non ho Debian

@b3knight: Grazie a te! Il team di Deluge offre già pacchetti molto aggiornati per Ubuntu, io stesso uso i loro :)

@Ciccio Pasticcio: Chiedi un po’ troppo, sì. Xlink non è in Hardy :)

@Al_Diseel: Anche a te rispondo con il repo di Kubuntu cfr “KDE 4 per Ubuntu Gutsy, in dieci minuti ;)“)

@bluetrain: Ardour è già segnato nella mia TODO, rosegarden potrei aggiungerlo, Tcl/Tk sono librerie, quindi nisba :)

@*Gian*: Ok, nella TODO anche glipper

22. Glipper 1.0 per Ubuntu Gutsy [pollyrepo] « pollycoke :) - 11/02/08 @ 21:30

[...] tante volte richiesto e finalmente promesso, ecco il pacchetto di Glipper 1.0 per Ubuntu Gutsy nel repository pollycoke [...]

23. Giaku - 13/02/08 @ 12:02

Bhe fa nulla Felipe! Grazie cmq per lo sbattone che ti fai ogni giorno per la "commiuniti"! Ciao!

24. Walt - 13/02/08 @ 16:57

Ciao Felipe ! mi piacerebbe tanto trovare nell Pollyrepo Evolution 2.14
Complimenti per l’ottimo lavoro, pollyrepo, news , how-to e tutto :)

25. Gimp 2.4.4 per Ubuntu Gutsy [pollyrepo] « pollycoke :) - 13/02/08 @ 19:55

[...] Repository [...]

26. Mikele - 14/02/08 @ 16:26

Ciao, oggi ho aggiunto i tuoi repo e purtroppo sto avendo dei problemi. Nel gestore aggiornamenti mi dava alcuni aggiornamenti, tuttavia una schermata mi dice che devo fare un avanzamento parziale della versione del sistema, provo ma alcuni pacchetti compiz, gimp, gnome etc…. non potevano essere autenticati. Ho chiuso, ho riaperto il Gestore e alla finestra che mi è apparsa (avanzamento parziale) ’sta volta l’ho chiusa e ho installato gli aggiornamenti. Finito ciò, c’erano ancora altri aggiornamenti che però non possono essere selezionati, inoltre se riprovo a fare l’avanzamento parziale, mi dà il medesimo errore sopra descritto solo che ’sta volta i pacchetti sono solo questi:
compiz-core
compiz-dev
compiz-gnome
compiz-plugins
compizconfig-backend-gconf

Comunque spengo il pc, quando lo riaccendo, trovo la poco gradita sorpresa di avere le finestre senza bordi! Ovviamente avevo abilitato gli effetti compiz personalizzati. Come mai ho questi errori, sia per gli aggiornamenti che soprattutto per compiz? Come posso risolvere? Aspetto vostre risposte. Ciao!!!

[email protected]

27. Cursori Oxygen per Ubuntu Gutsy [pollyrepo] « pollycoke :) - 16/02/08 @ 11:09

[...] Repository [...]

28. Al_Diseel - 17/02/08 @ 21:37

ecco una richesta nn impossibile stavolta :)

Traverso: giovane programma x audio editing ecc ecc

Pensaci su

29. aMule 2.2.0~svn20080218 per Ubuntu Gutsy [pollyrepo] « pollycoke :) - 20/02/08 @ 0:08

[...] Repository [...]

30. http://barcaro.myopenid.com/ - 20/02/08 @ 9:59

Ciao Felipe, è normale che in questo momento abbia dei problemi ad aggiornare aptitude?

Err http://download.tuxfamily.org gutsy/ Release.gpg
Impossibile connettersi a download.tuxfamily.org:80 (88.191.250.18), tempo limite di connessione esaurito
Err http://download.tuxfamily.org gutsy/ Translation-it
Impossibile connettersi a download.tuxfamily.org:80 (88.191.250.18), tempo limite di connessione esaurito

31. andrea - 21/02/08 @ 0:02

domandona domandona…evolution 2.21 si riesce a portare su gutsy?

32. Matteo - 21/02/08 @ 9:38

Richiesta: che ne dici di portarci kile2.0? è già in hardy…
Grazie!

33. fym - 27/02/08 @ 18:34

Felipe cosa ne pensi di impacchettare come nella precedente edizione il gtk2engine con clearlooks di hardy per Gutsy…..dai che le nuove tab sono carine e se upgrado direttamente con i repo di hardy mi upgrada anche altre librerie importantissime

__> Gtk2engine clearlooks

34. Dareus - 1/03/08 @ 18:09

per aggiungere il supporto a kopete per jabber (seguento la guida KDE su Kubuntu Gutsy ….) è necessario installare qca2 in una versione più aggiornata rispetto a quella contenuta nei repo, potresti aggiungerla al tuo?

35. Tracker 0.6.6 per Ubuntu Gutsy [pollyrepo] « pollycoke :) - 3/03/08 @ 18:03

[...] Repository [...]

36. Gimp 2.4.5 per Ubuntu Gutsy [pollyrepo] « pollycoke :) - 9/03/08 @ 17:56

[...] Repository [...]

37. obo - 16/03/08 @ 7:18

non mi fa aggiornare gimp :’(

38. obo - 16/03/08 @ 7:55

allarme rientrato. bye!

39. WhitePhoenix - 20/03/08 @ 11:52

amule non va:
-Err http://download.tuxfamily.org gutsy/ amule 2.2.0~svn20080218-0ubuntu1~pollycoke1
403 Forbidden
Impossibile ottenere http://download.tuxfamily.org/pollyrepo/gutsy/amule_2.2.0~svn20080218-0ubuntu1~pollycoke1_i386.deb 403 Forbidden

40. NickM - 22/03/08 @ 23:31

@Felipe musicista:
riusciresti a creare un pacchetto funzionante con un emulatore di un Theremin?

Ne ho provati tre (slat, ptheremin e spacetheremin), am non sono riuscito ad ottenere nulla. A parte qualche crepitio con ptheremin….

41. NickM - 2/04/08 @ 23:41

A qualcuno di buon cuore viene voglia di fare un .deb per Gutsy di Openoffice 2.4.0 ?

L’installazione convertendo con alien il file rpm funziona, ma Synaptic dopo è un po’ … incasinato.

42. Pidgin 2.4.1 per Ubuntu Gutsy « pollycoke :) - 8/04/08 @ 13:47

[...] Repository [...]

43. Liberation Fonts per Ubuntu Gutsy « pollycoke :) - 14/04/08 @ 17:04

[...] Repository [...]

44. FabioA - 15/04/08 @ 22:31

… compiz 0.7.4 … ? :-)

45. nziria - 14/05/08 @ 20:52

a quando il repo per hardy

46. Kimbo^ - 21/05/08 @ 13:19

Mi mancano i tuoi repo… quando potremo goderci quelli per hardy?

47. felipe - 21/05/08 @ 20:02

@nziria:
@Kimbo^:
Non appena ci sarà qualcosa di interessante, non temete e grazie per la richiesta ;)

48. Hein - 22/05/08 @ 22:00

aspetto con ansia i repo per hardy

ps. rispondimi alla mail!!

49. Firefox 3 RC1 per Ubuntu Hardy [pollyrepo] « pollycoke :) - 25/05/08 @ 14:49

[...] Repository [...]

50. Maqix - 25/05/08 @ 18:55

Ed ecco il repo Hardy Grande felipe!

51. nziria - 26/05/08 @ 13:24

mytico!!! :D

52. aMule 2.2.0+SVN 20080525 per Ubuntu Hardy [pollyrepo] « pollycoke :) - 26/05/08 @ 15:53

[...] Repository [...]

53. Krikkian - 27/05/08 @ 12:30

Ottimo, i tuoi repo son davvero buoni !

54. Zagabria - 27/05/08 @ 14:51

Non c’è che dire, proprio massiccio ed affidabile.

55. robegue - 27/05/08 @ 18:56

MA SONO UTILIZZABILI ANCHE PER DEBIAN?

56. mentos - 29/05/08 @ 19:25

non riesco ad installarlo , mi dice che la dipendenza libqt4-network non si può soddisfare…..come fare?

57. mentos - 29/05/08 @ 19:31

scusatemi ho sbagliato pagina!!!!!

58. Pidgin 2.4.2 per Ubuntu Hardy [pollyrepo] « pollycoke :) - 9/06/08 @ 15:28

[...] Repository [...]

59. Skype su Ubuntu 8.04 Hardy Heron con PulseAudio [HowTo] | Oskar NRK blog - 11/06/08 @ 12:24

[...] Flash va in palla perdendo l’audio allora è il caso di provare Flash 10 beta, lo trovate sul repository di [...]

60. elcamilo - 15/06/08 @ 15:16

http://www.amule.org/

"I’m happy to announce the release of aMule 2.2.1 - the "Excuse me, have you seen my 2.2.0 release anywhere?" version.

I want to highlight some features from the countless bug fixes and improvements made:

* Protocol Obfuscation
* UPnP support
* Network protocol updated to eMule 0.49a (including large file support)
* Kad 2.0
* Improved skin support and country flags
* Support for compilation with MS Visual Studio

….."

61. Marco - 1/07/08 @ 6:09

Da ieri sera: “Anche io Pollyrepo!” <:-)
Il ‘tuo’ rhythmbox e’ molto + ganzo! Grande!
Ciao,
Marco

62. koteko - 5/08/08 @ 20:27

Felipe perche’ non ci metti anche Arora? Non riesco a trovare un buon repository…credo non ce ne sia uno ufficiale :)

63. tosky - 5/08/08 @ 21:39

@koteko
Potresti rigenerare il pacchetto a partire da quello Debian (perché arora è in sid e in lenny).

64. Pierdo - 8/08/08 @ 5:57

Ciao Felipe, e complimenti vivissimi! Una miniera di info! Specialmente per coloro che muovono i primi passi.. (indovinate uno a caso tra questi??..) :)

Volevo chiederti/vi: da poco ho installato su un [email protected] una Ubuntustudio 8.04.1-amd64 (per poterci suonare uno strumento musicale, kernel rt), e mi servirebbe sapere se posso aggiungere nel mio sources.list il tuo repository, soprattutto per tener aggiornate applicazioni come ad es. Rhythmbox ed altri.

Mi fate sapere se si può fare questo?

Grazie mille a tutti!! ;)

65. Caratteri “da leccare” su Ubuntu Hardy « pollycoke :) - 25/09/08 @ 1:25

[...] Repository [...]

66. Marco - 17/10/08 @ 18:37

sono previsti repo anche per l’intrepid? basta modificare “hardy” con “intrepid” nella sources list?

67. Darkon - 22/10/08 @ 21:00

Sempre io il caro rompi Darkon ^^ scusate, ma una bella guida su come fare per creare un bel pacchetto deb funzionabile su tutte le distro derivate da debian, cosi da aiutare adeguatamente chi fà lo sporco lavoro. Sono convinto che così gli utenti linux aumenterebbero e la conoscenza si divulgherebbe con altrettanta velocità. Forse sono troppo uto.pista. ^^ e non ho nemmeno la moto ^^

(commentando accetti implicitamente le Regole di pollycoke, leggile!)