jump to navigation

Pagine corrispondenti, a partire dalla più recente:

Usare l’installer per i driver nVidia su Ubuntu

In Avanzate, per Guru!, Felipizza la tua distro, Guide, Post Imperdibili il 10/10/06 @ 17:19 101 commenti

12/01/07: sistemata una svista (grazie anima!)
01/11/06: invece di disinstallare i pacchetti Ubuntu si disabilita il modulo “nv” (grazie ZioFork!)
11/10/06: disinstallare i pacchetti ubuntu prima di usare l’installer
10/10/06: aggiunta la dipendenza a xserver-xorg-dev (grazie davide!)

Questo micro howto è qui per tutti quelli che vogliono installare Xgl/AIGLX, magari seguendo la guida “Ubuntu Dapper + XGL + Compiz“, oppure la nuova “Ubuntu Edgy + AIGLX + Compiz“, e hanno bisogno di un punto di riferimento per installare i driver nVidia sulla propria Ubuntu, in particolare usando l’installer originale di nVidia per poter ad esempio godere del supporto ad AIGLX che viene solo con nuovissimi driver non ancora pacchettizzati per Ubuntu.

Leggi il resto…

 

Xgl per utenti ATI: piccole note alla guida ufficiale

In Avanzate, per Guru!, Guide, Post Imperdibili il 27/09/06 @ 16:01 50 commenti

di raxxerk
(modificata da felipe)
29/09/06: piccole modifiche e aggiunta una nota di dolore :D

Nota: purtroppo le info sono un po’ frammentarie. Assicuratevi di leggere i commenti che trovate in fondo alla pagina, contengono correzioni ed esperienze diverse, io purtroppo non posso verificare la correttezza e mi limito a correggere solo le cose più evidenti. Grazie a chiunque voglia segnalare altro!

Queste note sono indirizzate agli utenti ATI che hanno seguito la guida “Ubuntu Dapper + XGL + Compiz“, che è scritta specificamente per schede video nVidia. Come al solito ricordiamo che se si mescolano informazioni di altre guide non si garantisce alcun risultato (N.d.F.).

Una volta seguita tutta la guida di felipe, se si vuole avere un Xgl funzionante bisogna compiere alcune semplici operazioni prima di riavviare.

Supponendo che abbiate installato gli ultimi driver ati e quindi abbiate ricavato i deb dal file .run presente sul sito della ati, x una corretta installazione di xgl + compiz avete bisogno di avere una copia di backup del pacchetto:

xorg-driver-fglrx_8.29.6-1_i386.deb

Ok seguendo la guida di felipe avete prima ottenuto l’accelerazione 3d e poi vi avete installato tutti i pacchetti necessari. Quando installate le mesalib però vi vengono rimpiazzati 2 file (/usr/lib/):

libGL.so.1
libGL.so.1.2

Dovete quindi copiare quei file in un posto sicuro e ripristinare quelli forniti dai driver ATI:

$ sudo mkdir /opt/mesa
$ sudo cp /usr/lib/libGL.so.1 /opt/mesa/
$ sudo cp /usr/lib/libGL.so.1.2 /opt/mesa/
$ sudo dpkg -i --force-overwrite xorg-driver-fglrx_8.29.6-1_i386.deb

Ora al posto di “compiz –replace gconf” da mettere in gnome-session-properties è meglio creare questo script in /usr/bin/

$ sudo gedit /usr/bin/startcompiz

#!/bin/sh
gnome-window-decorator --replace &
DISPLAY=:1 LD_PRELOAD=/opt/mesa/libGL.so.1.2 compiz --replace gconf

(tre righe in tutto), rendere eseguibile:

$ sudo chmod 755 /usr/bin/startcompiz

e aggiungere a gnome-session-properties semplicemente:

/usr/bin/startcompiz

E’ tutto

 

In attesa che mi sistemino il PC

In News, Vita Reale il 26/09/06 @ 2:34 1 commento

I maledetti fulmini e saette mi hanno lasciato senza PC al ritorno dalle sudate vacanze, questo lo avevo già scritto. Cosa succede nel frattempo? Il finimondo! Quel genere di finimondo che mi piacerebbe un sacco testare sul mio PC ._.

Spero che domani me lo consegnino perché non vedo l’ora di riassemblare il tutto - e zombificare di nuovo questo - per poter fare due o tre cose:

Leggi il resto…

 

Aggiornata la guida a Xgl su Ubuntu Dapper

In News, Umorismo spicciolo e..., Vita Reale il 6/06/06 @ 21:10 8 commenti

aaaaaargh1.jpgOggi stavo per prendere il PC e buttarlo dalla finestra.

Uno può sopportare che la vita sentimentale vada a rotoli, che i musicisti con cui uno suona sono bravissimi ma delle teste di …. con caratteri di …. e perfino che i biglietti per il Messico costano troppo …ma cribbio se non funziona bene GNOME si fanno le pazzie! :D

Riassumendo: torno a casa, accendo il PC, controllo la posta, scrivo qualche pensierino, bla bla bla …ah ecco volevo leggere con calma quell’interessante articolo EU vs USA, clicco sulla mia fida deskbar e scrivo USA… niente, smanetto un po’, niente, controllo che il backend beagle sia attivo, ancora niente, ma che …? Perdo un’ora nei meandri dei file di configurazione di GNOME gconf Mono Deskbar… niente

Beagle sembra “svogliato”, non lo usavo più da un po’ ma ricordavo che funzionava! Invece fa che i vecchi file già indicizzati li trova, quelli nuovi non li registra, sembra abbia noie con inotify, …oppure con gamin? e se fosse il kernel? provo con un altro utente… e funziona! Insomma vi risparmio tutte le ipotesi (ovviamente secondo google sono l’unico al mondo ad avere questo problema) e la faccio breve:

Il casino risaliva a quando ho configurato Xgl e compiz. Il metodo che ho usato per lanciare compiz (con .Xsession) letteralmente mandava in tilt gnome-session, e gnome-session per qualche strano motivo mandava in tilt solo beagle -.-

Beh cmq adesso ho risolto, se qualcuno ha usato la mia guida per installare Xgl e compiz farebbe meglio a controllare la sezione relativa a come fare partire compiz all’avvio di GNOME, giuro che adesso funziona tutto bene, usando direttamente gnome-session :D

Per la cronaca, ecco l’interessantissimo articolo su UE vs USA, ma vi avverto che la seconda parte è una boiata :)